Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Good day,

Today, my Cisco AnyConnect Client suddenly stopped working and started giving the following error messages:

1st dialog: VPN Service is not available.
2nd dialog (after pressing mandatory OK): The VPN Agent service is not responding. Please restart this application after a minute.

I have searched the internet for possible fixes and have tried the following things:

  • Uninstalling and re-installing the software. (As administrator and whatnot)
  • Connecting with AnyConnect network adapter on and off.
  • Disable Internet Connection Sharing (ICS) service.
  • Trial and error turning off other services to see if they somehow conflict.
  • Turn on services that were also turned on on another laptop that does have a working client to see if somehow certain required services got disabled.
  • Allow service to interact with desktop (In the "Log On" tab of the vpnagent service)
  • Manually starting vpnagent service.
  • Uninstalling, deleting any leftover Cisco directories, deleting Cisco registry entries, restarting, and then install again.
  • Deactivating windows firewall, windows defender, and Avira antivirus.

Some odd things I have noticed:

  • When changing the account to "Log On" in the vpnagent service to LOCAL_SERVICE or NETWORK_SERVICE, I can at least start the service and it will allow me to enter credentials to the vpn I want to connect to. However, it will always instantly give an error when the right credentials are entered. (Tried using wrong credentials and it rightfully tells me that they're wrong)
  • When manually trying to start vpnagent service with "Log On" account LOCAL_SYSTEM it immediately stops after starting. Sometimes the service gets stuck in a loop, infinitely trying to start and stop at rapid succession. At this moment, my laptop ventilator is blowing like mad so I restart.
  • When manually trying to start vpnagent service sometimes the following error message is given:

Windows could not start the Cisco AnyConnect Secure Mobility Agent service on Local Computer.

Error 1067: The process terminated unexpectedly.

  • On the other two setups mentioned below, the network adapter for AnyConnect are actually turned off when the VPN connection is working. Is it supposed to be off?

Some other things I have tried that worked, but not for my own Windows installation:

  • Installing the same client on Ubuntu OS on the same laptop (works like a charm)
  • Installing the same client on another laptop running the same Windows 7 version (works like a charm)

I am totally out of ideas. Any suggestions are greatly appreciated!

share|improve this question
    
I just had this issue on Windows 8.1 and the accepted solution fixed it as well –  Hoppe Nov 9 '13 at 14:11

5 Answers 5

up vote 2 down vote accepted

It somehow started working again. For the sake of helping other people in my same position I will add the step I took that might have solved it:

A few months ago I installed Spybot Search & Destroy and used the immunization tool that came with it. From my searches on this topic I noted some people mentioning that the Cisco client needed to adapt a host file to work. Apparently Spybot decided that the client was not allowed to do this. After undoing the immunization and uninstalling Spybot the vpnagent service magically started working!

I'm not 100% sure this was the actual solution since my VPN worked before even when the immunization was still on. However I suspect that the conflict between Spybot and Avira antivirus might have something to do with this non-deterministic behavior.

share|improve this answer

I found this article after receiving this error - seemingly out of nowhere. The steps that resolved my issues were:

1) Open Windows Explorer
2) Navigate to c:\windows\system32\drivers\etc
3) Move all files in the root to a new folder you create - any name is fine, I used 'old'.
4) Authorize the move in User Account Control.
5) Start Cisco AnyConnect client. You should not receive the error message.
6) Completely exit Cisco AnyConnect client.
7) Move HOSTS from 'old' back to c:\windows\system32\drivers\etc
8) Start Cisco AnyConnect client. You should not receive the error message.

These steps are different than the ones proposed earlier in the thread - no restart into Safe Mode was required.

share|improve this answer

I was having the exact same problem. I ended up restarting Windows in Safe mode with command prompt, renaming hosts to hosts.old in C:\Windows\System32\drivers\etc, restarting Windows in normal mode and then Cisco AnyConnect worked correctly.

Mental note: Do not use Spybot Immunize anymore.

share|improve this answer

I had the same problem and solved it by renaming the hosts file. I run Spybot Search and Install on my computers all the time and it does not interfere with the operation of VPN. However it does seem to affect the installation.

share|improve this answer
    
Welcome to Superuser, can you provide more details to where these files are stored? –  50-3 Sep 20 '13 at 3:00

Wanting to clean up my Windows 7 computer, I shut off several annoying processes and hosts via Spybot and since Cisco started the "VPN service is not available" error message.

I then realized that manually starting the vpnagent.exe (or related) in C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client did not launch anything at all.

Therefore I downloaded version 5.0.07 of the Cisco VPN Client (from WSU Page) in the attempt to repair that malfunctioning VPN agent and solved the problem for me.

After install, AnyConnect did not show any error any more (no system restart).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.