Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 8, PC.

I found solutions for when computer wakes up itself because of special network packets. This can be turned off in the device manager -> network devices -> power managment. The same goes for mouse, keyboard..

However, when I put my computer to sleep and forget to turn off the speakers first (I usually notice them by the buzzing sound (not a hi-fi)) and I turn them off after computer is asleep, it immediately wakes him up.

Sound devices has no "power managment" tab in device manager, so I wonder how to fix this problem. Is there no solution other than not forgetting to turn the speakers off before the computer? I have a compulsive need to solve this in a more technical way.

additional information: Speakers are plugged via earphone plug / audio jack.

share|improve this question
    
How are these speakers attached? USB or earphone plug? –  Daniel R Hicks Aug 11 '13 at 20:50
    
earphone plugged –  Ev0oD Aug 11 '13 at 21:29
    
You could try a different sleep level, Currently the default is s3 for most systems. Maybe try s2 or s4. –  spuder Aug 11 '13 at 21:35
    
If you happen to have a usb sound card you could borrow, I'd be curious if it has the same behavior. –  spuder Aug 11 '13 at 21:37
    
What sound card do you have? Just want to take a look at specifications. –  Nikolay Aug 11 '13 at 21:52

1 Answer 1

What I suspect is happening is due to Windows favor of little pop-ups and notifications that seem to take precedence over all else.

When you plug in your headphones or speakers to you headphone jack, I bet that windows give you a little pop up saying something like "a device was plugged into the headphone jack". And probably does the same when you unplug.

So if your computer goes to sleep when it thinks something is plugged in, and then you unplug it (or in this case turn it off), it gives a popup saying that it detected a change in the headphone jack, and hence, wakes the computer up to tell you.

Pointless right? To handle this, you can change the sleep level, as suggested int he comments above, or you could disable the notifications, which IMO would be nicer because they won't bug you anymore.

share|improve this answer
    
If you turn off speakers they remain plugged in to the port of sound card. Sound card can sense if something plugged in or not, but I doubt it will sense power condition of speakers. –  Nikolay Aug 11 '13 at 21:45
1  
@Nikolay, you'd be surprised at the insignificance that windows will use as an excuse for pop-ups. –  CaptJak Aug 11 '13 at 21:48
    
I would like to test out your approach with notifications, although I dislike the idea of disabling them, I would like to accept your answer, if it works. But I don't know how - since I am not sure what specifically you mean by them, I am not sure how to search for it. A hint, maybe? Thx. –  Ev0oD Aug 11 '13 at 22:43
    
@CaptJak, it's not up to windows to decide. Most likely, is not even up to the soundcard, it's the jack itself notifying the connection. Your answer would make sense if OP was unplugging the speakers, but turning them off would not trigger notification (think earphones, with no power source) –  gnp Feb 16 at 23:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.