Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm renting webspace with SSH access and I want to host a GIT repository on it. The problem is that GIT is not installed on the server, which is running Solaris and therefor it is difficult for me to get GIT running there. I've tried various ways to install GIT on the server, but none of them was successful. The system on the server is this:

> uname -a
SunOS gaffer 5.10 Generic_142901-13 i86pc i386 i86pc

Solution Approach 1 (compiling GIT for solaris)

There is no gcc on the server, or I couldn't find it. So I tried to build a cross compiler for solaris under Ubuntu, because I do not have a solarix box with gcc available. The idea is to afterwards upload the cross compiled GIT from Ubuntu to the solaris server.

I've followed this reciepe: building the cross compiler. In the step "make all-target-libgcc" I get the error

stdio.h: No such file or directory

I could not resolve this error. Google didn't help and I don't really know what I'm doing when building the cross compiler. This solution should be feasible because others have been able to build such a cross compiler.

Solution Approach 2 (download GIT for solaris and unpack it on server)

On the GIT site, I see that GIT is available for solaris. I failed to download the solaris version from a MAC and from Ubuntu, because the site offers only installers for the operating system in which my browser is running. I was also unable to trick the site into thinking that I was using solaris to run my browser.

I then found a dowload for GIT for solaris at http://ftp.riken.jp/Sun/sunfreeware/i386/5.10/git-1.7.6-sol10-x86-local.gz . I was then not able to install this under solaris into my webspace. I have no access to pkgadd (because I don't have root) under solaris and I did not find another way to extract the solaris package. I think this should be fairly easy if I know the right command to unpack it; it doesn't matter under which operating system I unpack it, because I can upload the unpacked files to the webspace afterwards.

Solution Approach 3 (get help from webspace provider)

I've called the webspace provider and ask them if they are willing to install GIT. They declined this. I then asked for information on how to install it into my own space by myself. I'm waiting since for the call back or email from their second level support.

Can you help me with any of the above approaches, or is there any alternative way to get GIT on this solaris box?

UPDATE: The webspace provider called me and told me this was impossible with shared hosting. I explained them how this can be achieved, even without administrative work from their side, and finally convinced them that it actually is possible. They agreed because of repeated questions from various customers to address this to their product manager. My inquiry to get some admin of them on the phone for 10 minutes and give me information on how to get GIT into my own webspace was declined again without proper explanation.

After this call, which shows that those guys are incapable of handling their own technology, and that they are also not even willing to help customers in a way which is almost effortless for them, I'm so disappointed that I decided to cancel the contract with them and move on to a hoster which uses some standard linux as operating system. I'm sure there are plenty and using GIT there will be simple.

share|improve this question
    
Sad to read that. This is exactly the reason why "The Internet" == "Solaris" is an equation that is not valid anymore. I guess the step to cancel the contract was absolutely the best option here. Currently I am working with Solaris 11.1. git is included in the standard IPS repository there. –  JoBo Aug 23 '13 at 18:35
    
Yes. I got linux based webspace now, also shared hosting, and I got my GIT repository working within less than an hour after ordering the webspace. –  Daniel S. Aug 26 '13 at 10:18
    
You could have also tried getting an old Solaris Express or OpenSolaris and compile git on those. –  Cristian Ciupitu Oct 21 '13 at 18:59
    
@CristianCiupitu: You're right I could have gotten some solaris. However, I had been trying to get this working for days without success, so it was the better alternative (I'm not used to solaris at all) to simply buy other webspace with linux and good support instead of spending some more days with fiddling around. I also wonder why there was nobody with access to a solaris box who opted to help me out. I would gladly compile anything once off on any of my machines if someone needed it and couldn't get it done on his own. Not even the support from that company was helpful. –  Daniel S. Oct 21 '13 at 22:15
    
What do you mean you have no access to pkgadd ? pkgadd is a standard Solaris command which is part of even the core minimal installation or is it just you have no root access on your system ? –  jlliagre Jul 13 at 16:52

2 Answers 2

The opensource scm manager which will be an alternative instead of solaris git , which supports git, hg and svn also.

I'm using it on my production environment currently, which is quite stable without any problems.

www.scm-manager.org

share|improve this answer

As you have no package installation privilege (i.e. you are not root or similar) you cannot install new or update existing packages for obvious security reasons.

The first option, compiling from source, is generally the best approach when done on Solaris. gcc is commonly bundled with Solaris 10 and installed in /usr/sfw/bin but might have not be installed by your provider.

Building and using a cross-compiler is overkill. It is complex and has a lot of pitfalls as you experienced. A simplest alternative would be to install a Solaris release on a VirtualBox or whatever VM you like running on an x86 host you own and build from here.

The second option, hacking a regular package to install it in a different directory is likely doomed. While commands exist to convert a package to a directory tree, you will be faced with at least two issues: sunfreeware packages install in /usr/local but you have no write access to it so need to install them elsewhere. As some path internal are likely hard-coded to /usr/local, the program will probably fail. The second issue is the downloaded package will likely requires extra packages as a dependency leading to extra burden.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.