Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I enabled file sharing and in options SNB sharing on my Mac but still none of the computers in my local area network can reach it. They can ping the computer and can ssh but only sharing doesn't work. any ideas ?

share|improve this question
    
Have you tried only via IP instead of the name? eg. \\192.168.1.50 –  Chealion Nov 16 '09 at 23:27
    
yes. i tried that. –  ufk Nov 17 '09 at 11:39
add comment

3 Answers 3

Just a noob check, but did you select the account you want to share in the SMB prefs?

Have you tried changing the NetBIOS Name and Workgroup in the network settings? I find that I often have to set these before my "new macs" will show up on windows PCs.

To do this visit "Network" in system preferences, then select your primary/active network adapter and then click "Advanced..".

Network Prefs

Inside this click the WINS tab. Should look something like this:

WINS Tab

Set your computer name and the workgroup you want the mac to be part of here.

share|improve this answer
    
thanks for your advice but unfortunately it did not do any good. when i try to mount from my linux box i get the error 'Host is down'. –  ufk Nov 28 '09 at 20:02
    
How odd. Have you double checked the config on your linux box? –  JonB Dec 13 '09 at 14:14
    
+1; it is unbelievable that SMB settings like these are hidden far away from the regular SMB settings. –  Jeroen Wiert Pluimers Dec 5 '13 at 16:52
add comment
up vote 0 down vote accepted

reinstalling apple snow resolved the issue. thanks for all of your support.

share|improve this answer
add comment

The following solution worked for me: insert the password in CAPITALS! Special chars and numbers as usual.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.