Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since a few days, I'm only getting maximum 2Mbps downstream over the local wi-fi. Before that, it was a lot faster. Another notebook on the same network still gets 30+Mbps. Latency (<15ms) and upstream (1Mbps, a good value for a typical connection in the region) are unaffected on both machines. Tested with connection benchmark sites and downloads in a download manager. Android phone and tablet connected to the same network both get 16+Mbps downstream.

In the Windows 8 wi-fi status dialog, it shows full five bars of connectivity and a theoretical connection speed of 130Mbps.

I'm not aware of any software on my PC that might have changed it, although I did install some system-heavy software recently (SQL Server Express, VS2013 Express Preview and similar). From the timing, the installation of those would fit to when I first noticed the speed problems.

According to the Windows 8 task manager, my network has 0% workload. When I run a speed test, this jumps up to 2Mbps (all other processes but Chrome are at 0Mbps), but there it seems to be magically limited by something and doesn't go above, even though I know the router could do at least ten times as much. I can't figure out what causes this.

I do not have control over the router because I'm staying at someone else's place, but I do know that nobody touched it (e.g. to manually set QoS rules to affect me).

What gives, any ideas?

It's such a weird problem that I don't even know which keywords to google for.

Things I've tried:

  • Reboot
  • Remove and recreate wi-fi network connection
  • Remove and redetect network adapter
  • netsh int ip reset
  • On the network adapter, remove all "items" but IPv4

Environment:

  • Broadcom 802.11n adapter on HM55 chipset for Core i5 CPU
  • Windows 8 Pro with all updates installed
  • D-Link DIR-615 router
  • Connected via WPA2-Personal with AES encryption (automatically chosen by Windows, not manually modified)
share|improve this question
    
Older WiFi hardware? Depends on what 802.11a/b/g/n that you used, you will speed cap yourself. The router may support all a/b/g/n but if your own laptop only support b then that is your speedcap. Or another possibility you may connect to the "guest" side of the wifi (some router can have those) and the guest wifi have speed cap? –  Darius Aug 13 '13 at 5:16
    
@Darius It's a fairly standard Broadcom 802.11n adapter on an HM55 chipset, as common for a Core i5 CPU. If it was connecting with only b, wouldn't the Windows' status dialog then show a lower theoretical connection speed than the 130Mbps it currently does (see above)? Guest side of the wifi is certainly a possibility, although I'm not sure how I ended up there without changing my connection settings – or how to leave it (I tried killing the network and reconnecting). Thanks for your input! –  hheimbuerger Aug 13 '13 at 5:26
add comment

1 Answer

After switching the Encryption Type in the Wireless Network Properties from AES to TKIP, I get downstream speeds of 22+Mbps again. Pings and upstream speeds are basically unaffected (11ms -> 10ms, 0.9Mbps -> 1.0Mbps).

This is reproducible: after switching back to AES, I get the old downstream speeds again.

Explanations are welcome, all of this makes no sense to me.

When it was still fast a few days ago, was I still on TKIP? Then what switched me!? Or why is AES suddenly so much slower than TKIP? Why is it just as fast on other networks?

Edit: A bit a research made me believe that by switching to TKIP, I implicitly also switched from 802.11n to 802.11g (because TKIP is not allowed on n due to its security problems). That would also explain why I'm now seeing a connection speed of 54Mbps. So now the question becomes, why does g work, but n stopped working?

(Mind you, I still prefer a connection speed of 54Mbps with 22Mbps actual throughput over connection speeds of 130Mbps with 2Mbps throughput.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.