Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

What could cause a 945KB Excel file to grow to 35MB without any warnings?

Tips:

  1. There are table formattings that converted ranges to Tables and I converted them back to Range. Can it be that?
  2. Macros crashed Excel several times and file recovery pane appeared but I always choose close without re-saving anything.
share|improve this question

migrated from stackoverflow.com Oct 30 '09 at 14:57

This question came from our site for professional and enthusiast programmers.

    
Is it possible to mark one of these answers as correct? (I dont know how migrated questions work). For me @Insomnic answer soled it :) –  Ole Henrik Skogstrøm Apr 2 '13 at 13:54

7 Answers 7

Just delete the remaining unused rows and columns from top to the bottom and left to the right, after deleting it will appear again but the formats which were used before will have gone, it really works, try it.

share|improve this answer

I found out by trial and error. Started copying sheets to a new Book and saw that one sheet full with data, was formatted by me, selecting the excel 2007 option "format as table" and even converted back to range (which took considerably long)I think the coloring of cells cause this... I wonder who have done this at microsoft. cruel stuff!

share|improve this answer

If you have turned on workbook sharing so that multiple users can update the document simultaneously, then the default is to keep a change history for 30 days. This can cause the document to grow ridiculously large pretty quickly.

share|improve this answer

it may you enable the versioning feature of your document and each every save it will be create new version . that may be reason for suddenly increase size of file .

share|improve this answer

It would seem the most likely cause is the addition of cells either by formatting or bad data input. An easy way to see this is by looking at the scroll bars. If the drag bar is extremely skinnny and you are only using 100 rows (or A-G columns) then you have a lot of extra rows/columns being remembered. Copy/pasting the required data into a new workbook will fix this but may cause problems depending on the type of data involved. A way to remove the hose unnecessary cells is by dragging the scroll bar to the end (don't use the scroll wheel) and then selecting and deleting the "extra" rows or columns.

Check the reviewing options as well. If the document has been passed around a few times and markups have been applied with out a full accept/deny of those changes, the document can get very large. This is more common with PowerPoint and Word but can affect Excel.

share|improve this answer
2  
This is very good advice. –  Botond Balázs Oct 31 '09 at 0:00

I too faced such problems. If you zip this 35MB Excel, the zip file will be very small. Am I right?

Try this Workaround - Try copying and pasting the range of required cells into New Excel File and check the new file size.

share|improve this answer
    
This method is better than the remove formatting method because it also removes any undo history. –  Chris Nava Oct 30 '09 at 16:09
    
@Chris Nava: However there is a risk of data loss in the process (bad range, bad copy, etc.). So check several times if you took everything. –  Gnoupi Oct 30 '09 at 16:12
    
Except if you have a large workbook of formulas and links this is not practical. –  dcc Sep 8 at 22:30

Last time I experienced this, the problem was that someone set the background of thousands of cells to white. It seems that Excel stored these separately. Try selecting all cells and removing formatting.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.