Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Many people are using a second version of µTorrent because they don't like the ads (even though one can disable ads on v3).

It is generally recommended to update software because of potential security vulnerabilities that are fixed over time.

Are there any known vulnerabilities in µTorrent v2 that have been fixed in v3? If so, what are they?

share|improve this question
1  
There's two more sensible options here - firstly to turn off ads, and using the newer versions, or secondly, do what I did, and vote with my feet by switching clients. There's almost never a good reason to use an old version –  Journeyman Geek Aug 13 '13 at 9:07

2 Answers 2

up vote 2 down vote accepted

I guess you can never be sure if there are no security vulnerabilities, but a quick search through a version history of µTorrent doesn't show me any fixed security issues in 3.0+.

share|improve this answer
1  
A version history requires somebody to keep track of every single change, document the change, and then describe it. Its not unheard of that secruity problems are simply resolved and never properly documented in these types of projects. I go the simple approach just disable the ads or switch clients. –  Ramhound Aug 13 '13 at 11:18

Here is a list of µTorrent vulnerabilities from the CVE database. Skimming through, I can see at least one (CVE-2010-3129) affecting versions up to 2.0.3.

share|improve this answer
    
upvoted; sorry i didnt pick this answer, but it was a coin toss. –  Wuschelbeutel Kartoffelhuhn Aug 13 '13 at 20:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.