Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm configuring a system for use as a media centre, running Mythbuntu 12.04. Everything is working, short of the remote. I've configured my remote, and it I start lirc from the command line, it works fine. If I run it from the init script service lirc start it doesn't work. (For this purpose, work means to have irw show an output). In both cases I'm using exactly the same command (in fact, for running it from the command line, I'm just copying the command that is present in ps -ef). Both cases have lirc running as root (at least that's what ps -ef tells me). Both cases produce exactly the same info in syslog.

Command to start lirc:

sudo /usr/sbin/lircd --output=/var/run/lirc/lircd --driver=devinput --device=/dev/input/irremote

syslog output (start lirc, start irw, stop irw, kill lirc):

Aug 13 22:06:05 Myth-FJ lircd-0.9.0[4917]: lircd(devinput) ready, using /var/run/lirc/lircd
Aug 13 22:06:05 Myth-FJ lircd-0.9.0[4917]: accepted new client on /var/run/lirc/lircd
Aug 13 22:06:05 Myth-FJ lircd-0.9.0[4917]: initializing '/dev/input/irremote'
Aug 13 22:06:28 Myth-FJ lircd-0.9.0[4917]: accepted new client on /var/run/lirc/lircd
Aug 13 22:06:35 Myth-FJ lircd-0.9.0[4917]: removed client
Aug 13 22:06:42 Myth-FJ lircd-0.9.0[4917]: caught signal
Aug 13 22:06:42 Myth-FJ lircd-0.9.0[4917]: closing '/dev/input/irremote'

I'm completely stumped.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.