Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So after my last mobo went dead, I installed a new one. It is the AsRock 970 Pro3 R2.0.

Everything is connected as it should be. I get no beeps, the fans spin, the hdd's spin, but there is no activity on the hdd led, and nothing is shown on the screen.

I have tried every step in this list:

I have tried booting up with no memory, 1 memory bank, switching the bank to different slots, I've tried unplugging everything except the absolutely nescessary cables, I've tried clearing CMOS, nothing works. I've never had one beep at all.

I'm out of options now. I hope one of you guys have an idea about how to fix this.

Please note: I have read other topics about this on superuser, but none solution has worked so far. Thank you

share|improve this question
If you take out everything except CPU and PSU, it shoud beep like you have no RAM. If it doesn't, then you've probably got a bad motherboard, CPU or PSU. Next on the list is try a new PSU, if that doesn't help, try a new CPU or motherboard. If you don't have spares, take it to a shop. – Ƭᴇcʜιᴇ007 Aug 13 '13 at 17:48
Sounds like the hdd led is simply not connected. If the fans stay on, the hdds stay powered up, and there are no beeps then your system actually is trying to POST but failing to do something. You have to determine what that is if you want help. If your system shuts off thats normall connected to a short. – Ramhound Aug 13 '13 at 18:29

1 Answer 1

up vote 0 down vote accepted

@techie007, thx for your suggestions! We took everything out to check if the problems where caused by the ram, cpu, gpu, psu or mobo. We swapped everything from other computers, and in the end it was indeed the PSU that caused our problems.

It is weird though, that the whole system gained power from the broken psu, the fans and hdd's where spinning, but the system wouldn't boot. However after installing another PSU the system booted up immediately :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.