Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get a VM time synced with a 64-Bit Windows 8 host upon host shutdown and startup. Linux Integration Services is installed on the virtual machine and all integration services are enabled and running. The issue is that when the host is gracefully shutdown, the VM is suspending rather than shutting down itself. When the host is then powered on, the guest resumes from it's suspended state and the guest's time is off by the time that the host was powered off. The only way that I can get the VM to match the host is if I have the "Automatic Stop Action" in Hyper-V Manager set to "Turn Off" which isn't good for the database. I'm experiencing this on CentOS 5.6 and CentOS 5.8.

Thank you

share|improve this question
Have you tried: ? – Brian Aug 18 '13 at 5:34
I have not tried this as the issue is with the VM not shutting down gracefully. "Shut down the guest operating system" is selected as the Automatic Stop Action in Hyper-V Manager. I have no time drift, just that when the host shuts down... the VM is being saved instead of shutting down itself. When I manually shut down and then start the guest the time is synced perfectly with the host. Also, it should be noted that viewing messages in /var/log indicate that the guest is not starting or shutting down with the host. I do appreciate the response. – amateurstanding Aug 21 '13 at 0:18

It sounds like you dont have the Hyper-V integration services installed. That allows time synchronization between the guest and the host.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .