Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've downloaded Linux (Elementary OS) so I can start writing code in Vala in my spare time, but there is a problem.

I bought a new PC last month, it's an All-In-One (HP Pavilion something something etc) and when you turn the computer on, you normally see the command-prompt-style-interface for a little while with the 8-bit looking text with options down the bottom of the screen, like um, F7 and F10 to enter setup mode, etc.

But not on this computer, a HP Pavilion f2300. The only thing you see from the time you press the power button, till the time Windows asks you to sign into your account, it the HP Logo and the Windows 8 progress ring (the circle dots that appear when something loads). Nothing else.

I have tried pressing F7, F8, F9, F10, F11, F12 etc during the startup process but have not been able to get into BIOS settings so I can set the USB as the boot device.

I also went into Control Panel > System > Administrative Tools > System Configuration, then Boot tab, and there is only one drive listed - which is the PC's internal hard disk.

And there appears to be no option to select something like "Boot from other device or USB" or anything like that.

What are the different ways one can change Boot priority/what to boot with in Windows and how can I get it to display BIOS settings when the options aren't even displayed?

And if you have any experience with this computer, please do let me know how to boot into BIOS while starting up the PC.

Any help is much appreciated. Thanks!

share|improve this question
providing a model number would be useful – Keltari Aug 14 '13 at 2:18
Sorry @Keltari it slipped my mind. The model is HP Pavilion f2300. – jay_t55 Aug 14 '13 at 2:29
@Aeron - hitting the Del key at the splash screen does not get you into bios? – Carl B Aug 14 '13 at 2:35
I've just been able to get into BIOS setup by repeatedly tapping the F10 key while the HP logo is displayed. No matter what options I select or what combination of options I select - It refuses to boot anything but the internal hard disk. – jay_t55 Aug 14 '13 at 3:06
up vote 1 down vote accepted

Apparently HP systems require you to press esc (the instructions for getting into the bios tell you to press escape repeatedly) and then f9. I'd suggest doing this as you start up the system, since I have no idea how much time you have to do this

Going into bios should be useful, since ubuntu hasn't been signed to work with secureboot yet, and you may need to disable this option to boot into ubuntu.

share|improve this answer
Thanks, I'll try this aswell, maybe it'll show me some options that actually work. – jay_t55 Aug 14 '13 at 3:06
thanks, that got it to show up :) – jay_t55 Aug 14 '13 at 3:37

To boot from a bootable usb you will need to go to the boot menu when its booting up then go into the Bootable USB option. If it doesn't show, go into windows, restart and then you should see the usb option, if not, reboot again to boot menu, if it is still not showing, reboot again or see if the usb is plugged in correctly, if yes then boot to windows, remove the usb and put it back in correctly and then restart, go to boot menu and you should see now the usb option.

share|improve this answer
Please can you try to explain your answer in a better way. At the moment it's very hard to understand. – DavidPostill Feb 19 '15 at 11:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.