Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently we bought dedicated server with Windows Server 2012 Standard.It's allowing 2 people at a time.So I want to allow more people at a time.

How can I do this?

share|improve this question

3 Answers 3

If you want more than 2 concurrent connections your computer is now considered a "Terminal Server" and you must pay for "Remote Desktop Services client access licenses" (RDS CALs) for people to connect.

Here is the contact link to contact a Sales Representative to negotiate what kind, quantity, and price of licenses you need.

share|improve this answer
    
1) Regarding your first link, that is for the 2008 server. Is there a 2012 update for that page? (since the question is asking for 2012 server). 2) If the extra installation is called a "Terminal Server", then what's the terminology for a default terminal server that has the 2-concurrent-connections limit? –  Pacerier Feb 28 at 16:08
    
@Pacerier 1) The licensing management interface has not changed from 2008 to 2012, the 2008 guides can still be used. 2) The terminology for the 2 connection limit default server is "Administration Mode" –  Scott Chamberlain Feb 28 at 17:01
    
I mean before our server is considered a "Terminal Server", what kind of server do we call it? Isn't it actually also "terminal server"? –  Pacerier Mar 2 at 4:05
    
@Pacerier "Termial Server" is just one of the many Roles server 2012 can be (In fact a Remote Desktop Session Host, the thing this question and answer is about, is only a single a subfeature of the Remote Desktop Services Roll) and a server can be many or none of the predefined rolls. What you call it is up to you, all microsoft cares about is you are not violating the CAL licencing you did or did not pay for. –  Scott Chamberlain Mar 2 at 5:35

Are you referring to Remote Desktop? If so, you can try this:

  1. Log into the server and open MMC.exe.

  2. File → Add/Remove Snap-in → Group Policy Object → Add → Finish → OK.

  3. Double click Local Computer Policy → double click Computer Configuration → Administrative Templates → Windows Components → Remote Desktop Services → Remote Desktop Session Host → Connections.

  4. Limit Number of Connections = 999999.

  5. Restrict Remote Desktop Services users to a single Remote Desktop Services session = DISABLED.

share|improve this answer
1  
by default Limit Number of Connections = Not configured.Still it allows 2 users at a time. by default it allows 2 people at a time. Is it right what I am saying. –  subbu Aug 14 '13 at 13:37
1  
I mention Limit Number of Connections =3 and selects enabled option. Also I did Restrict Remote Desktop Services users to a single Remote Desktop Services session = DISABLED.Still it's allowing 2 people. –  subbu Aug 14 '13 at 13:44
    
I'm not sure what else to say in that case. I don't have a Server 2012 to test this on myself. After you made the change, did you force a Group Policy refresh? –  Jack Aug 14 '13 at 14:28
    
Is this missing a step? How to apply this setting so it takes effect? –  NickG Jan 19 at 17:59
    
@NickG, On my server it seems immediate. But you can try gpupdate or gpupdate /force. Max is 2, if you want more than 2 see Scott's answer. –  Pacerier Feb 28 at 16:06

Follow these instructions.

  1. Enable Multiple RDP Sessions
  2. Log into the server using Remote Desktop.
  3. Open the start screen (press the Windows key) and type gpedit.msc and open it
  4. Go to Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections.
  5. Set Restrict Remote Desktop Services user to a single Remote Desktop Services session to Disabled.
  6. Double click Limit number of connections and set the RD Maximum Connections allowed to 999999.

Screenshot describing solution

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.