Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using CentOS 6.4 operating system and everything was good until power-system crash :/ After successfully reboot I am normally asking for login/pass and after login shell redirects me to login shell again :/ Typing wrong password couses typical wrong-pass-communicate.

Trying to check file-system with LiveCD, everything is ok and placed on the right place.

No idee what could possibly go wrong :/ Any ideas?

EDIT: I found out that my OS starts fluently on runlevel 5, but before failure it was set to run level 3. How can I list the diffrences between running processes on rl-3 and rl-5? On rl-5 all of my accounts work well.

SOLVED: I research a little bit about my issue and solution is: http://www.centos.org/modules/newbb/print.php?form=1&topic_id=16329&forum=44&order=ASC&start=0

Summary:

  1. vim /etc/pam.d/login
  2. change: session required /lib/security/pam_limits.so to session required /lib64/security/pam_limits.so
  3. Save :wq
  4. Reboot: init 6
share|improve this question

migrated from stackoverflow.com Aug 15 '13 at 3:20

This question came from our site for professional and enthusiast programmers.

    
Try to login as root and check if the /home partition has been successfully mounted –  hek2mgl Aug 14 '13 at 18:36
    
Is your /home encrypted? –  Moje Aug 14 '13 at 18:48
    
None of file system directories is encrypted. Only possible way to log into system is change runlevel to single user mode. –  user2683634 Aug 20 '13 at 6:37
    
Have you tried to login as root and checked if /home was mounted? –  hek2mgl Aug 20 '13 at 10:32
add comment

1 Answer

It is just a guess, but because I had the same issue recently it may help. Because of the system crash, some SELinux labels might be damaged. To fix it:

  1. Boot any live distribution and mount your disk
  2. Edit /etc/selinux/config and change it to SELINUX=permissive
  3. Reboot

If it works, use restorecon to fix the labels and re-enable SELinux.

share|improve this answer
    
I change this specified value to permissive but problem still exists. What can be interesting default value was set to "SELINUX=disabled". One more thing which I did not mention before: when a try to log into single user mode it works. Then switch runlevel from 1 to 3 and try to log in but issue mentioned above occurs again. Is it possible for example that GRUB config or sth like that was corrupted and now lock logging act? Or mayby unknown network issue blocks authorization process? Will be grateful for any clues :) –  user2683634 Aug 19 '13 at 15:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.