Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I love the autocompletion for Chrome's Omnibox, don't get me wrong. However, much of the time I just want to search for something. When I begin typing into the Omnibox and then press enter, I just would like to do a search by default. Is there a way to force Chrome to search as opposed to selecting the top autocomplete suggestion?

I know I could just press backspace and then enter, but I'd rather just switch the default behavior to search before selecting an autocomplete entry. I'm okay with pressing down a couple times to select the autocompletion entry.

How do we switch the top two items?

As in the image above, is there a way to switch the first two options?

share|improve this question
    
It's not just OSX. This started happening for me just a couple months ago on every other Chrome browser, and I dearly wish I could disable it. When I type c o l o r+Enter, I should not find myself at a search results page for "colorado lottery"! –  Henry Keiter Aug 19 '13 at 13:46
    
I just stated OSX because I have just recently begun being bothered about this which coincided with my starting to use OSX. I didn't put an OS tag on this because I wasn't sure offhand if it was a problem in other OS's. –  agweber Aug 19 '13 at 14:38
    
All of the answers thus far have just been adding steps rather than actually solving the request of switching the ordering of the Omnibox's behavior. I have a feeling this one won't get answered. –  agweber Aug 25 '13 at 13:44
add comment

3 Answers

Disable the autocomplete at will with a space at the end of your search term. For example you can simply press:

color␣↵
share|improve this answer
    
I can also use backspace. This doesn't solve my problem, just shows me another method of switching to what I want the default controls to be. –  agweber Aug 25 '13 at 13:40
    
I suppose you could fork Chromium, change that one part of the default behavior in the source code, compile it, and run your modified version. But that's sort of like saying "use a different browser" so I suspect not an ideal solution. –  hoosierEE Aug 26 '13 at 16:18
    
That seems like the only way to go really. Still not going to accept any answers in case someone in the future comes up with something. Bounty awarded (had 42 minutes left). –  agweber Aug 26 '13 at 17:56
    
Thanks, and good luck. –  hoosierEE Aug 27 '13 at 12:08
add comment

Use alternative omnibox

Fauxbar is a free Google Chrome extension that provides a page that acts like Firefox's Awesome Bar.

For install:

  1. Open webStore - Fauxbar, install.
  2. In menu bar, click Options.

enter image description here


Additional in Firefox

  1. Type about:config and hit Enter.
  2. Change the value of the property urlbar.maxRichResults.

enter image description here

Note: once even had the flag in Chrome -omnibox-popup-count for this, but unfortunately it was removed, see more here.

share|improve this answer
    
Not necessary for Firefox - pressing Enter uses the entered data. Using an auto-complete entry requires a click or down-arrow + Enter. –  harrymc Aug 20 '13 at 8:50
1  
Adding Fauxbar is adding another step instead of reducing them. Unless I'm mistaken, this is just a replacement for the new tab page. This doesn't help when I simply want to search and navigate away from the current page. It does have capabilities of search from Omnibox but that requires typing F+space beforehand. Is there a way to override this requirement? –  agweber Aug 20 '13 at 14:26
add comment

Chrome is suggesting coloradolottery.com because the website is in your browsing history.

You can disable the prediction service inside of Chrome, but it will still default to suggesting websites from your history first.

The prediction service is typically turned on by default. Follow the steps below to turn it off.

  1. Click the Chrome menu Chrome menu on the browser toolbar.
  2. Select Settings.
  3. Click Show advanced settings.
  4. In the "Privacy" section, deselect the "Use a prediction service to help complete searches and URLs typed in the address bar" checkbox.
share|improve this answer
    
I would still like prediction services to come up under the drop-down and be able to select one of them via down arrow + enter. Also, regularly removing browsing history is not a viable answer because I want to be able to search for a variety of items, including things that are closely related to sites that I've browsed. –  agweber Aug 25 '13 at 13:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.