Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed a VirtualBox VM from http://virtualboximages.com/CentOS+6.4+x86_64+LAMP+Server+VirualBox+VDI+Virtual+Computer.

My VM has access to internet, and I can ping the host. I've set a static IP address in /etc/sysconfig/network-scripts/ifcfg-eth0.

Webmin is preinstall, and I can reach http://192.168.1.14:1000 from the host.

However I'm not able to ping or reach my VM with SSH. Also, iptables is disabled...

I don't see what I'm missing.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

From what you said, it looks like you have bridged networking enabled for your guest since you can reach your webmin console.

Make sure you have the sshd service up on your guest OS. If you do netstat -tln, you should see a list of the listening ports on your machine. If you see port 22 on the list, then you probably have some sort of firewall preventing you from accessing your port. If you don't see port 22 then you most likely don't have sshd running. You should see something like 0.0.0.0:22 (or :::22 for ipv6).

You can check your service by running service sshd status. If it's not running, do the following:

service sshd start
chkconfig sshd on

Those lines will start the service and enable it to start at boot time.

As far as the ping, you may have ICMP requests disabled, which is done by default sometimes for public web servers to prevent DOS attacks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.