Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A former developer backed up all of our files using plzip. We no longer have the server he used to compress them and have not been able to find a program to decompress these files. We have Windows 7 and Red Hat Enterprise Linux machines. It doesn't really matter which but can somebody tell me how to install lzip or plzip? The files are here http://www.nongnu.org/lzip/ but I have no idea what to do with them. Nothing I've tried has worked.

share|improve this question
    
For the heck of it, see if 7-zip can deal with it. –  ultrasawblade Aug 16 '13 at 12:18
    
It can't. That's the first thing I tried. Maybe there's some version that does but I haven't found it. –  eisaacson Aug 16 '13 at 14:51

1 Answer 1

up vote 2 down vote accepted

These will run on a Red Hat machine, you need to compile them.

Download http://download.savannah.gnu.org/releases/lzip/lunzip-1.3.tar.gz

Put it in the same dir as your files. (backup the files somewhere)

From the command prompt run

gunzip lunzip-1.3.tar.gz
cd lunzip-1.3
./configure
make
sudo make install # <-- this command to install the program, this is optional but requires you to run lunzip from the directory you compiled it in
cd ..

If no errors occurred you should now be able to unzip your files using the command:

lunzip <filename>

Or if you chose not to run the install command:

./lunzip-1.3/lunzip <filename>

EDIT:

If you don't have the developer tools installed the appropriate way to install them is with:

yum groupinstall "Development Tools"
yum groupinstall "Development Libraries"
share|improve this answer
    
Thank you. This is progress. When I try the first make, I get cc -W -O2 -c -o carg_parser.o carg_parser.c make: cc: Command not found make: *** [carg_parser.o] Error 127 –  eisaacson Aug 15 '13 at 22:06
    
I've edited my answer. –  Daniël W. Crompton Aug 15 '13 at 22:54
    
Great! I got it to work without the install. The install seems to have failed though. Do I need to do something else to make it install so I can use the lunzip command? Although man lunzip works, lunzip <filename> does not. When I ran make install, it output "if [ ! -d "/usr/local/bin" ] ; then install -d -m 755 "/usr/local/bin" ; fi install -p -m 755 ./lunzip /usr/local/bin/lunzip" if [ ! -d "/usr/local/share/man/man1" ] ; then install -d -m 755 "/usr/local/share/man/man1" ; fi –  eisaacson Aug 15 '13 at 23:28
    
You'll need to prepend the full path to so it looks something like: /home/user/lunzip-1.3/lunzip –  Daniël W. Crompton Aug 15 '13 at 23:38
    
shouldn't I be able to install it so i can just type lunzip <filename> like any other command? –  eisaacson Aug 15 '13 at 23:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.