Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Raspbian, and I am using this as a display device for a TV in a retail centre. I run Chromium on startup with this line in .profile:

xinit /usr/bin/chromium --kiosk --incognito www.mysite.com

...however none of the solutions to disable screen blanking seem to work (although they do work if I am in the Raspbian GUI). It is quite important (as you can imagine) that the display screen does not go blank.

Does anyone have any solutions to this?

I have tried the following:

setting the xinitrc file as in this example http://raspberrypi.stackexchange.com/questions/2059/disable-screen-blanking-in-x-windows-on-raspbian

setting exec /usr/bin/X -s 0 dpms -nolisten tcp "$@" in xserverrc

setting blank timeouts in /etc/kbd/config

setting /etc/lightdm/lightdm.conf with the following line: xserver-command=X -s 0 dpms

non of the above have worked

I have noticed a possible solution which entails installing xscreensaver then disabling it but I do not know how to make it run on startup.

share|improve this question
    
... Which solutions? – Ignacio Vazquez-Abrams Aug 16 '13 at 10:32
    
You can probably edit your answer to include everything you have missed) – Journeyman Geek Aug 16 '13 at 10:48
    
ok, question edited – coolblue2000 Aug 16 '13 at 10:51
    
Check this answer – VL-80 Aug 16 '13 at 15:51
    
@Nikolay, that answer does not work either..... – coolblue2000 Aug 25 '13 at 9:18

You can try this solution.
comment this line:

@xscreensaver -no-splash

And add following lines:

@xset s off
@xset -dpms
@xset s noblank
share|improve this answer
    
Adding the above xset lines to /etc/xdg/lxsession/LXDE/autostart has worked for me in the past. I've not had to use the xscreensaver line. – joat Jan 22 '14 at 11:49

All that is needed to stop the screen from going blank system wide is in /root/cmdline.txt. Add:

`consoleblank=0`

after console=tty1 and reboot.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .