Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to migrate some old Windows installs into VirtualBox. I have tried a few different tools including Clonezilla and Disk2VHD to create my virtual disks but cannot get the newly created virtual machines to boot. So far I have made a Windows 7 machine and a Windows XP machine and both BSOD with a 0x000007B code. I have googled the code and followed several tutorials to fix this (most assuming your install is on a real HDD) including running MBR repair tools and CHKDSK /r with no improvement.

How do I get my virtual HDD to boot?

Installing Windows from scratch works fine, but I want to revive these old installs.

I run Ubuntu 13.04 as my Host OS. I have a clean install of Windows 7 in a VM that I am using to run any Windows based recovery tools (such as Disk2VHD). The old Windows installs are on old hard disks that have been put into USB caddies.

share|improve this question
add comment

1 Answer

This is possible, but hard and/or painful... Its so easy in linux and still so hard on windows!

You have to prepare the windows BEFORE the migration, you have to install scsi/sata drivers of the new computer and sometimes change the current drivers to a generic one (if the current driver is not from MS or weird controlers). Note that RAID setup are very hard to clone, unless they use the same controller.

Windows XP required one to load a registry file to allow one to do this:

http://support.microsoft.com/kb/314082

And delete all HD to drive letter mapping in the HKLM\SYSTEM\MountedDevices before shuting down (well, not all drivers are required, just the boot one, but if you remove all, you can map the drive letters back later, so no big problem)

With windows 7, you should just need to install the new drivers and if needed, boot in safe mode on the new setup. If you forgot to install the new driver, try this howto

The easy way might be to use the sysprep to put the windows in to a state ready for cloning. Sysprep will prepare the system and to keep all data choose the option System Out-of-Box-Experience and Generalize (to load all generic controllers drivers)

http://www.makeuseof.com/tag/making-sure-windows-7-will-boot-after-changing-the-motherboard/

Please note that on first boot you have to create a account, create something just to continue, but later you can login with the old one (and remove the new created account)

Finally you can also try to use acronis backup/restore , that claims that can do this.

Also, if you download HirensCD (google for a download link), you can have a LiveCD with windows and do some changes (like change the registry, copy files, install some drivers, fix the MBR and boot menus, etc ) that might help for those that didn't prepare the system BEFORE the change.

share|improve this answer
    
I have found a HirensCD image and booted into 'MiniXP'. I can access the virtual HDD but how do I set it up to not get the boot errors? As far as I can tell my MBR is ok but may have a problem with drivers (as the hardware has technically changed with the migration into the virtual machine)? –  Andrew Heath Aug 28 '13 at 14:41
    
you have to enter the regedit pe (IIRC) to edit the virtual HDD registry and remove the entries in the (remote) HKLM\SYSTEM\MountedDevices. If you are getting error 0x000007B, i assume it already load the correct IDE/sata/scsi controler, so it should be enough –  higuita Aug 30 '13 at 15:06
    
I removed the registry entries but the VM still won't boot (and the entries repopulate). I assume I need to replace the entries with something meaningful so it doesn't automatically repopulate and crash. Also, I assume I may need to somehow add drivers for it to find on startup. –  Andrew Heath Oct 19 '13 at 13:01
    
no, they are automatically reconstructed on a sucessful boot. Are you sure you are removing the HD windows entries and not the liveCD windows one? you need to load the HD windows registry keys on the regeditPE –  higuita Oct 19 '13 at 13:36
    
I am certain I am loading and editing the registry on the HDD. –  Andrew Heath Oct 23 '13 at 14:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.