Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I opened terminal today and realized that the usual startup text:

my-macbook-pro:~ myUsername$_

has been replaced by:

mscs256-24197:~ myUsername$_

I tried googling but couldn't find anything. I'm pretty sure the computers in our math building are named mscs-xxx (math sci comp sci) so maybe somebody logged in remotely? When I type in the command hostname it replies with: mcsc-24197@mySchool.edu.

Any ideas on how this could have happened (I just disabled remote login and haven't used any of those computers in months) and how to fix it would be much appreciated. thanks.

share|improve this question

1 Answer 1

Os X uses complex auto-magic to set the host name:

  1. The name provided by the DHCP or BootP server for the primary IP address
  2. The first name returned by a reverse DNS (address-to-name) query for the primary IP address
  3. The local hostname (set in the Sharing pane of System Preferences)
  4. The name localhost

The following post provides different fixes for OS X 10.5 & 10.6+: How can I stop Mac OS X overriding my hostname when I receive a DHCP request on Snow Leopard?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.