Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is a minor problem but it kind of annoys me because it used to work. When I set Google Chrome as the default browser on Windows 8 Professional 64-bit, it works as it should (with links opening in Google Chrome and everything), except Internet Explorer is coloured as the default browser. I find it weird because it only happens with Google Chrome. When I set another browser like Firefox as the default browser it colours it as the default browser like it's supposed to.

enter image description here

This is IE with chrome - IE seems to be set as default yet in reality Google Chrome is

enter image description here

Firefox Nightly with IE

share|improve this question
    
It all looks grey to me - could you add some screenshots - even if you don't have the rep to embed images directly give a link and someone will edit it in. You can screenshot the start screen by pressing the windows key and the printscreen key together, and looking in my pictures –  Journeyman Geek Aug 17 '13 at 4:42
    
Okay so this is what it's like when Google Chrome is the default browser: puu.sh/43Kfw.png And this is what it's like when Firefox Aurora is the default browser: puu.sh/43Ki9.png Notice how Google Chrome doesn't change its icon like the others do, instead Internet Explorer does. –  Kelyn Ferguson Aug 17 '13 at 4:59
    
OH. You're running the nightly. Does it do metro? –  Journeyman Geek Aug 17 '13 at 5:15
    
I've edited in the images - feel free to edit any of the text I added in –  Journeyman Geek Aug 17 '13 at 5:18
    
I tried getting the nightly to work with metro but it wouldn't work. Anyway, do you have any idea why the Chrome tile isn't changing to reflect its default status? I noticed that when I go into the chrome://settings/ page to make it the default browser, I get two Internet Explorers pop up to make default, and one of them corresponds to Chrome: puu.sh/43L2R.png (this is with Internet Explorer as the default, trying to change Chrome to default). Could this be related to my problem? –  Kelyn Ferguson Aug 17 '13 at 5:28
show 2 more comments

1 Answer 1

You can only register 1 default app as modern Browser so only 1 icon is shown. In your second picture the Firefox is default browser so only the Firefox Metro Tile is shown.

The default new experience enabled desktop browser always appears as a square tile. Any secondary tiles belonging to the default new experience enabled desktop browser also appear with new user experience tile visuals.

MS explains this here:

http://go.microsoft.com/fwlink/?LinkID=243079

share|improve this answer
    
Yes, I know that. You don't understand. I have the Google Chrome browser set as default, yet the Internet Explorer tile is coloured as default. –  Kelyn Ferguson Aug 17 '13 at 6:07
    
the second screen shows the desktop IE and the metro firefox (as default browser) –  magicandre1981 Aug 17 '13 at 6:08
    
I'm talking about the first screen. The second one was only to show what is the expected behaviour (which happens with all browsers EXCEPT FOR Google Chrome). –  Kelyn Ferguson Aug 17 '13 at 6:09
    
ok. File this as a bug in the Chromium bug tracker. –  magicandre1981 Aug 17 '13 at 6:10
    
Okay, thank you :) –  Kelyn Ferguson Aug 17 '13 at 6:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.