Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried upgrading my chrome 26.x by going to the "about google chrome" page -- but unlike my windows chrome, the linux chrome(centos 6.0) v 26.x did not offer to upgrade to the latest version.

I downloaded the latest linux chrome for fedora x86_64 bit and then tried to install it -- however, that command failed saying that my libstdc++ needed upgrading. So, I then tried to upgrade my libstdc++ to the new version; however, "yum install" didn't comply. What gives ?

foo@bar Downloads]# rpm -ivh ./google-chrome-stable_current_x86_64.rpm
    error: Failed dependencies:
        libstdc++.so.6(GLIBCXX_3.4.15)(64bit) is needed by google-chrome-stable-28.0.1500.95-213514.x86_64

foo@bar Downloads]# yum install libstdc++.so.6
    Loaded plugins: fastestmirror, refresh-packagekit, security
    Loading mirror speeds from cached hostfile
     * base: mirror.vietoss.com
     * epel: ftp.jaist.ac.jp
     * extras: mirrors.ispros.com.bd
     * updates: mirror.vietoss.com
    Setting up Install Process
    Package libstdc++-4.4.7-3.el6.i686 already installed and latest version
    Nothing to do
foo@bar Downloads]#
share|improve this question

3 Answers 3

up vote 0 down vote accepted

As of Chrome version 28, RHEL/CentOS 6 is no longer supported. You'll have to use Chromium instead. I used to recommend the howto at this page, which includes links to a Chromium repository for RHEL as well as instructions for using Chrome's Pepper Flash and PDF Viewer in Chromium, but the PDF viewer stopped working because it too required a newer glibc than RHEL/CentOS had. Richard Lloyd's Chrome installer is now the best option as of early 2014.

share|improve this answer
    
thank you. I went per your suggestion. –  anjanbacchu Aug 21 '13 at 10:53
  1. Linux users maintain packages through their package managers and repositories not download websites, thus auto-updaters don't fit in well with the modular package ecosystem.

  2. CentOS 6.0 is from 2011, please upgrade to the latest release (6.4). The official wiki guide or using the package manager.

  3. libstdc++.so.6 is a shared object file not a package. Surprised yum was able to deduce you meant the libstdc++ package - which as the output states, the installed version is the most recent version available in the repositories you have enabled for CentOS 6.0.

  4. The reason more recent versions of Google Chrome require a newer libstdc++.so than the one you have (you can check which version you have using readlink -e /usr/lib/libstdc++.so) is that it was "compiled against" it (or rather linked with it). Chrome's source code is not open thus you are unable attempt to recompile it for your system.

  5. The open-source Chromium browser, which Google Chrome is based on, which lacks some proprietary functionality but is a usable alternative is something can choose to compile for your system.

As stated, if you want the latest version without too much trouble you really need to upgrade your OS.

share|improve this answer
    
thanks for your answer <br>. I chose to accept polpo's answer given that it gives me a way to install the latest chromium on centos 6.0. I have other software installed on my box that I'm afraid of losing if I upgrade centos to 6.4. –  anjanbacchu Aug 21 '13 at 8:15

I installed Chrome 31 successfully on CentOS 6 with the script provided on this page.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.