Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried the answer

sudo chmod go-w

in my /Volumes/BOOTCAMP but I'm still getting the warning

It says

Insecure world writable dir /Volumes/BOOTCAMP in PATH, mode 040777

And when I echo $PATH

I get this:

/Users/anthonybrown/.rvm/gems/ruby-2.0.0-p195@railstutorial_rails_4_0/bin:/Users/anthonybrown/.rvm/gems/ruby-2.0.0-p195@global/bin:/Users/anthonybrown/.rvm/rubies/ruby-2.0.0-p195/bin:/Users/anthonybrown/.rvm/bin:/Applications/Postgres.app/Contents/MacOS/bin:/usr/local/opt/ruby/bin:/usr/local/share/npm/bin:/usr/local/bin:/usr/local/mysql/bin:/usr/local/bin:/usr/local/sbin:~/bin:/usr/local/php5/bin:/Library/Frameworks/Python.framework/Versions/2.7/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin:/Volumes/BOOTCAMP/opt/nuodb/bin:/usr/local/mongodb/bin

When I open my .zshrc file I don’t see /Volumes/BOOTCAMP/opt/nuodb. I’ve deleted it, any ideas?

share|improve this question
    
Am I not wording this correctly or is there no answer? –  pixel 67 Sep 7 '13 at 1:13

1 Answer 1

Try running this command:

sudo chmod 775 /Volumes/BOOTCAMP

As well as the one you did previously:

sudo chmod go-w /Volumes/BOOTCAMP

You might need to add the -R (recursive) flag to those commands to ensure all child files and directories beyond /Volumes/BOOTCAMP are affected as well. But I don’t feel comfortable recommending you do that right away since I am not familiar with this error in the context of Bootcamp’s needs and setup.

share|improve this answer
    
The issue has been resolved, it had something to do with a NoSQL database I installed. Once I removed the DB the issue went away –  pixel 67 Aug 24 at 11:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.