Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 7, service pack 1, 64-bit, NVIDIA GeForce 8800 GT. I used Power Options to configure the monitor to turn off after 10 minutes of inactivity. This works fine when I use the computer locally, but when I connect to the computer remotely using Remote Desktop two things happen:

  1. The monitor turns on when the remote user logs in (bad!)
  2. The monitor remains on even after the use disconnects (bad!)

Note that the user is closing Remote Desktop without logging off.

How do I prevent Windows from turning the monitor on when the computer is accessed remotely?


Update: I reconfigured the display to turn off after 1 minute of inactivity (previously it was 10 minutes). What I see is the display turning off, then turning on a few minutes later. The monitor then turns off a minute later and this process repeats every couple of minutes.

powercfg -requests after a wake-up returns:

DISPLAY:
None.

SYSTEM:
[SERVICE] \Device\HarddiskVolume2\Windows\System32\svchost.exe (CryptSvc)

AWAYMODE:
None.

powercfg -lastwake returns:

Wake History Count - 0

powercfg -devicequery wake_armed returns:

HID-compliant mouse
Microsoft USB Natural Ergonomic Keyboard 4000 (Mouse and Keyboard Center)
HID Keyboard Device (002)

powercfg -energy didn't return anything I considered meaningful.

The only other clue is that I've noticed my mouse batteries are low. Perhaps the mouse is sending random activity signals to the system? Is there a way for me to look up who woke up the display last?

share|improve this question
1  
Does the monitor turn off after 10 minutes of inactivity even while the user is logged in/the remote user logs out? –  Chipperyman Aug 18 '13 at 19:53
    
@chipperyman573, the display turns off (while the remote user is logged in) but turns on at some later time for no apparent reason. –  Gili Aug 20 '13 at 11:42

1 Answer 1

up vote 0 down vote accepted

In my particular case, installing Logitech SetPoint (drivers) seemed to have resolved the problem. I suspect the built-in drivers were outdated and waking up the monitor.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.