Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed CUPS and Avahi Daemon as it is documented here on a debian squeeze.

I can see the printer with my iPhone with iOS 6.1.3, so i guess avahi works fine. I can print a test page via the CUPS webinterface, so the printer itself and CUPS are working fine too.

But if i send a printing job to the airprinter with my iphone nothing is printed. I can't even see a job in the CUPS webinterface. It worked once a while ago when i first tested the setup. But just a view days later when i tried again nothing happened...

How can I debug where the job is lost?

My services file /etc/avahi/services/AirPrint-Brother_HP_LaserJet_4050_Series.service looks like

<?xml version="1.0" ?><!DOCTYPE service-group  SYSTEM 'avahi-service.dtd'><service-group><name replace-wildcards="yes">AirPrint Brother_HP_LaserJet_4050_Series @ %h</name><service><type>_ipp._tcp</type><subtype>_universal._sub._ipp._tcp</subtype><port>631</port><txt-record>txtvers=1</txt-record><txt-record>qtotal=1</txt-record><txt-record>Transparent=T</txt-record><txt-record>URF=none</txt-record><txt-record>rp=printers/Brother_HP_LaserJet_4050_Series</txt-record><txt-record>note=Brother HP LaserJet 4050 Series</txt-record><txt-record>product=(GPL Ghostscript)</txt-record><txt-record>printer-state=3</txt-record><txt-record>printer-type=0x1014</txt-record><txt-record>pdl=application/octet-stream,application/pdf,application/postscript,application/vnd.cups-raster,image/gif,image/jpeg,image/png,image/tiff,image/urf,text/html,text/plain,application/openofficeps,application/vnd.cups-banner,application/vnd.cups-pdf</txt-record></service></service-group>
share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.