Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a laptop running Ubuntu 12.04 with Tor. Now with following credentials Tor works fine with any SOCKS5 supported apps.

Host: 127.0.0.1
Port: 9050

This laptop is connected with WiFi router (192.168.1.10). I have an iPad which is connected to same WiFi router (192.168.1.5). Now I used following credential in iPad WiFi proxy settings.

Host: 192.168.1.10
Port: 9050

But this doesn't work. I think Tor is not listening over LAN. How can I make Tor listen to whole LAN network? Or 0.0.0.0?

share|improve this question
add comment

2 Answers

In Vidalia Control Pannel , open Settings. Go to Advanced tab. In front of Address, type your IP address (192.168.1.10).

share|improve this answer
add comment

Open torrc file, if you use ubuntu its in /etc/tor/torrc

and edit this line

SocksListenAddress 127.0.0.1

to this:

SocksListenAddress 192.168.1.10

Then just restart tor using

service tor restart
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.