Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am creating a bash script that will 'setup' a client machine running Fedora 19 (GNOME). I need to be able to permanently disable the screensaver with no user input. I found some (granted, old) documentation that suggested you could simply set the idle-activation-enabled to false:

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

This shows the change has been made (returns false):

gsettings get org.gnome.desktop.screensaver idle-activation-enabled

This however does not stop the screen from dimming and locking the screen. Does anyone have any ideas? Is this a problem with terminology? Is the screen dimming function not referred to as a screen saver?

share|improve this question

In Fedora 19, org.gnome.desktop.screensaver.idle-activation-enabled is deprecated and ignored. Set org.gnome.desktop.session.idle-delay to 0 if you do not want the screensaver to be activated.

share|improve this answer

I had to implement this requirement for a Fedora 19 virtual machine. I ran the following using the terminal as root to disable the screensaver:

gsettings set org.gnome.desktop.session idle-delay 0

You can verify it was set correctly by running:

gsettings get org.gnome.desktop.session idle-delay
share|improve this answer
    
Default is 300, just in case you want to reverse that. – Quandary Feb 21 '15 at 6:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .