Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to load Debian Linux on my Lacie ss4000e I have been trying to follow this tutorial http://d-i.alioth.debian.org/manual/en.armel/ch05s01.html#boot-firmware-ss4000e

I have tried to load it using both the ymodem method and the network method both end with a kernel panic.

[    2.412165] No filesystem could mount root, tried:
[    2.417094] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
[    2.425495] [<c001378c>] (unwind_backtrace+0x0/0xe0) from [<c0278254>] (panic+0x50/0x194)
[    2.433784] [<c0278254>] (panic+0x50/0x194) from [<c037cc08>] (mount_block_root+0x234/0x284)
[    2.442294] [<c037cc08>] (mount_block_root+0x234/0x284) from [<c037cde0>] (prepare_namespace+0x124/0x184)
[    2.451935] [<c037cde0>] (prepare_namespace+0x124/0x184) from [<c037c89c>] (kernel_init+0x12c/0x160)
[    2.461149] [<c037c89c>] (kernel_init+0x12c/0x160) from [<c000edf8>] (kernel_thread_exit+0x0/0x8)

The exact command of my last try is as follows

fis load rammode
g

Then I wait for it to reboot and hit ctrl+c

ip_address -l 192.168.1.3 -h 192.168.1.100
load -v -r -b 0x01800000 -m http /initrd.gz
load -v -r -b 0x01008000 -m http /zImage
exec -c "console=ttyS0,115200 rw root=/dev/ram mem=256M@0xa0000000" -r 0x01800000
share|improve this question
    
After more debuging and testing it looks like the initrd.gz format is a cpio archive, where as I think it should be a ext2, ( I tryed the same steps using the ramdisk.gz file system which is an ext2 and it at least boots, – Tim Holum Aug 19 '13 at 21:22

I had this issue using the daily builds.

If you are using daily build images, please try the stable squeeze installer build. This is the only one I could get to work. it's here.

as a side note, if you choose to use ssh to install, the password is "install" which you can see as a d-i parameter here.

Good luck. I tore out a lot of hair installing Debian on this box

share|improve this answer

I don't know anything about installing Debian on this device so this is a total shot in the dark.

But ...

I presume you're trying to boot an installer.

And I guess /dev/ram is meant to mount the initrd directly.

Maybe the fact that the initrd seems to be compressed ("initrd.gz") is causing an issue? Try uncompressing the initrd.gz to a plain initrd and see if it can boot that.

Of course I'm hoping the initrd is actually a single file when uncompressed. If it's a bunch of files you need to convert all those files into whatever image format /dev/ram expects, possibly.

share|improve this answer
    
I tryed this with the extracted image and got the same issue :( – Tim Holum Aug 19 '13 at 19:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .