Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My internet is extremely slow on some sites, the famous ones. Google, Facebook, etc. But then, the very next minute, they are superfast.

I got to know from somewhere that this is due to clogging and improper routing given that these sites are using IPv6. Link

How do I find out that when I am opening Facebook in Browser, I am hitting IPv6?
And then disable it.

I have a 15Mbps Fiber optics connection, and really want to find out what's causing some sites to open very slow, or not at all.

The problem exists in all browsers.
I use the same laptop in Office where I have a 10Mbps connection. It works good with a download speed of ~ 1.3MBps. Which means everything is fine and normal with my Office connection.

So please do not suggest using CCleaner, flushing DNS cache, using different browsers, etc. - for which I hate forums and Yahoo answers. Thanks and apologies.

Attaching a 10 KB file in Gmail (if at all it opens) is painful 2 minutes.

share|improve this question
    
Have you read the article you posted? It happens to have some solutions. –  Doktoro Reichard Aug 19 '13 at 22:24
    
You have almost no detail here. Please explain: What browser you are using, what operating system, whether you got a valid IPv6 address, your IPv6 routing table... –  Michael Hampton Aug 20 '13 at 0:10
    
@MichaelHampton, The problem exists in all Browsers. I am majorly using Chrome dev channel. Whether its a valid IPv6, is what I want to find out. –  Om Shankar Aug 20 '13 at 18:26
    
Open a command prompt and run ipconfig. –  Michael Hampton Aug 21 '13 at 23:57
    
Got the solution. The problem was in the wrong MTU Value in the Router. Reduced the value to 1452 from 1456. All sites open like a blaze now. –  Om Shankar Aug 22 '13 at 18:07

1 Answer 1

I got the solution to this problem. The problem was due to the wrong MTU settings which is common in my country for Broadband as well as Fiber optics users.

By default, Windows sets the MTU as 1500 for Point to point network connections. I think that's the highest value. But this high value can cause fragmented packets and packet loss, if not supported by your router. This would explain opening of sites slow, or partial opening.

I ran the following command first:

ping google.com -f -l 1472

1472 is the default value (when added with 28 bytes, which is reserved for IP/ICMP overhead = totals 1500)

I got the following message 4 times:

Packet needs to be fragmented but DF set

This means a value of 1472 is high. We can go on reducing it by 10. I got an un-fragmented ping on 1452:

ping google.com -f -l 1452

When I tried with 1453, 1454, etc., I got the first Fragmented message again.

Which means my no-loss MTU value is 1452 + 28 = 1480.
When I set it in Windows, all the sites opened up quickly and completely (no loading cursor).

Following is the command I used for setting my value (added 28):

netsh interface ipv4 set subinterface "Local Area Connection" mtu=1480 store=persistent

Local Area Connection is the name of my LAN connection in Network Settings. If you have installed a Wireless Router and connect to it for internet Wirelessly, then make sure you use the correct name:

netsh interface ipv4 set subinterface "Name of ur Wireless Connection" mtu=your-best-value-plus-28 store=persistent
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.