Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having this error with curl:

curl https://www.google.com -v
* About to connect() to www.google.com port 443 (#0)
*   Trying 2607:f8b0:400e:c01::67...
* Failed to connect to 2607:f8b0:400e:c01::67: Network is unreachable
*   Trying 74.125.28.103...
* Adding handle: conn: 0x4041f868e0
* Adding handle: send: 0
* Adding handle: recv: 0
* Curl_addHandleToPipeline: length: 1
* - Conn 0 (0x4041f868e0) send_pipe: 1, recv_pipe: 0
* Connected to www.google.com (74.125.28.103) port 443 (#0)
* error setting certificate verify locations:
  CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
* Closing connection 0

Ignore the network is unreachable... it happens with every https:// url, even if the network is reachable.

I won't install manually the certificates, cause it should get them automatically... ideas?

share|improve this question

Fix. I don't know what the problem was, but it was related to the certificates (ca-certificates) package.

It was fixed by adding ca-certificates and run update-ca-certificates

The distro I was using is Alpine LInux, so the commands are:

apk add ca-certificates
update-ca-certificates

In debian alike it should be:

apt-get install ca-certificates
update-ca-certificates
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .