Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I accessed the media card on a notebook computer (which I believe to be virus infected) and after that, the photos can only be seen on the camera. When I try to read the media card on another computer after that, it only showed a short cut (1 kb) link only. What can I do to remedy the situation?

share|improve this question

migrated from photo.stackexchange.com Aug 19 '13 at 23:19

This question came from our site for professional, enthusiast and amateur photographers.

    
possible duplicate of How can I recover deleted photos from an SD Card? –  mattdm Aug 19 '13 at 15:58
add comment

4 Answers 4

This is a very common virus which put your archives hidden. If you're using windows try this:

  • Open "Command prompt" or Windows + R and type "CMD".
  • Write this command: attrib -h -s -r -a /d /s f:\*
  • the "f:" is your directory, can be e: and so on.
  • this command will unhide your archives.

keep in mind that this doesn't mean that the virus were gone. Try to remove it with a good Anti-Virus. Let me know if works.

share|improve this answer
    
I'd strongly advise against doing anything with a computer which you suspect has a virus other than installing anti-virus software. –  Philip Kendall Aug 19 '13 at 19:32
add comment

I would recommend that you use a Linux LiveCD to try to access the card.

It sounds like something is hijacking the behavior of the card and trying to infect your computer, but a Linux LiveCD should be more resilient to an attack that targets Windows.

share|improve this answer
add comment

Looks like your media card folders and files have been marked "hidden" or "system" by the virus infected computer.

The easiest way to get the images saved is to use a known clean system, connect the camera to the computer and "COPY" off all the images from the camera.

After that is done, use the in-camera option to FORMAT (not the "delete all images" option) the card, effectively wiping the card to "factory empty" and you should be good to go.

share|improve this answer
add comment

it only showed a short cut (1 kb) link only.

This happened around me several times already. You probably aren't copying the images correctly.

  1. Remove the 1kb shortcuts, right click in the files you want to copy (you can select them all), click Copy.
  2. Right click in any empty area of the memory window and select paste.
  3. Check the results right clicking the files and checking it's Properties.

If still paste 1kb things then your system is infected and is making you a bad joke. In those cases you may use the command line copy command:

c:\> cd directory\with\photos
c:\directory\with\photos\> copy *.jpg e:\

this assumes your photos are in C:\directory\with\photos\, the photos are all JPG and your memory stick is E:. You may change things around.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.