Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, I had been using Notepad++ to open many be files - say, .txt, or .log, for example. And that is how I like it. One day, though, internet explorer suddenly started opening them, which I most certainly don't want. I think it might have started after an update.

Note, Windows 7, and IE 10.

So, in default programs, IE isn't set for anything like those - the only things that are set I cannot seem to remove. Anyway, .txt and friends - including .html - are not checked.

So, I don't know how to get it off. It USED to work. I tried reverting to IE 9, but the problem remains.

Note, in the description, it says Notepad++ Document, but the logo is of IE, and it opens in IE.

Any ideas?

Some pictures I cannot seem to post:

enter image description here enter image description here enter image description here enter image description here

share|improve this question
    
add comment

1 Answer

Have you already tried this. You need to associate the extension to a specific program to have a program open it by default.

Here is an article on managing your open with menu.

share|improve this answer
    
I had tried that. It sets it to Notepad++ Document, but for current default it lists XML Editor, which apparently is part of IE (?). Anyway, perhaps relevant is, in the traditional "open with" menu, N++ isn't listed alongside others, you have to browse manually. –  user3101220 Aug 20 '13 at 1:41
    
I added a reference to the open with menu. –  Suirtimed Aug 20 '13 at 1:46
    
That isn't specifically the problem - it wasn't listed there before either, but it worked. Anyway, seeing as how it worked before, and it certainly should now, I don't think additional tools is needed for this, though that might be useful for other occasions. –  user3101220 Aug 20 '13 at 2:06
    
At least for me the Default Programs / Set Associations works ok, it doesn't touch the file type description but immediately changes the default open behaviour to open in whatever is selected. @Pawnguy7: So when you select N++ in the dialog opened by Change program... button and hit ok, the Current default is still "XML Editor" in the file associations list? –  zagrimsan Aug 20 '13 at 6:56
    
Ah. It seems I was mistaken, sort of. I guess, by default, something is selected in the default program listings, and after selecting N++ via browse, they are still selected. Anyway, if I make it have nothing selected, then browse for N++, the button to apply it is grayed out. Note that N++ is not in the traditional programs directory. I think I had this issue before, but setting the associations from N++ itself fixed it, then, but unsetting/resetting them doesn't seem to have fixed it right now. –  user3101220 Aug 20 '13 at 14:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.