Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to remove stock Lua and build my own one, so I tried:

yum remove lua

But too many dependencies on the package and it does not allow me to remove it so I used rpm instead:

rpm -r --nodeps --force lua

It removed Lua. Then I built my own one. However yum crashes from now on, and every time I run yum (does not matter if it is yum install or yum list, or just yum), it gives me

error:There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   liblua-5.1.so: cannot open shared object file: No such file or directory

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.7.3 (default, Aug  9 2012, 17:23:57) 
[GCC 4.7.1 20120720 (Red Hat 4.7.1-5)]

If you cannot solve this problem yourself, please go to 
the yum faq at:
  http://yum.baseurl.org/wiki/Faq

I cannot even install lua back because it does not allow me to run. rpm is crashed too:

rpm: error while loading shared libraries: liblua-5.1.so: cannot open shared object file: No such file or directory

I have a version of liblua-5.1.so, but I tried to put the symbolic link in /usr/lib, and /usr/local/lib, it still gives this error. Please help... I do not want to reinstall.

share|improve this question
up vote 0 down vote accepted

It would appear yum depends on a specific version of the Lua library shared object file (liblua-5.1.so). The compile flags you used when compiling your own version of the library seem to be incompatible.

Therefore you should determine your architecture (uname -m) then download the lua i686 or x86_64 package from Fedora and install it with rpm to restore yum to a working order.


If you are unable to use rpm then obtain a Fedora LiveCD/LiveUSB. You will chroot into your install and attempt repairs. Here are some guidelines:

Determine which partition your Fedora / is on

sudo -i
blkid

Mount your Fedora partition

arch="i686"
mntDir="/mnt"
mount /dev/sdX# "$mntDir"
rpm -i lua-5.1.4-12.fc19.${arch}.rpm --prefix "$mntDir"

Chroot into install

mount -t proc proc "${mntDir}/proc/"
mount -t sysfs sys "${mntDir}/sys/"
mount -o bind /dev "${mntDir}/dev/"
mount -t devpts pts "${mntDir}/dev/pts"
chroot "$mntDir" /bin/bash

Debug install

yum --help
share|improve this answer
    
hi whenever I run rpm, it gives me error so basically im not able to install anything... even locally – texasbruce Aug 20 '13 at 17:07
    
Did you try the LiveCD + chroot? – justbrowsing Aug 21 '13 at 10:25
    
I ended up using similar thing... used a live cd and yum --installroot /mnt lua.x64_64 and its fixed. Thanks! – texasbruce Sep 4 '13 at 16:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .