Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to fix a compaq presario sr5027cl that belongs to a family member; it has more ram (2gb+256mb) then stated there and a new power supply. The computer was already in bad (virus ridden) condition so when I received it not booting into windows and only showing the blinking dash cursor, I decided to just go ahead and format the drive. This is where the problems start.

I plug the hard drive into my computer to save a few important documents but I can't access the drive. It is really messed up but since it has some important files I run a recovery program and am able to get to them out.

So I format the drive (I think the PC couldn't see the drive at first or was it before recovering the files; anyway I fixed the problem thanks to the internet but I'm a little fuzzy on this since I took an extended break) but I can't access the partion with vista which sucks cause I don't have a vista cd, I'm still using xp on my desktop.

I don't know anyone with a cd so I torrent 2 (yeah this thing is cursed) the second one boots and I rejoice, a little too soon. Insert the key the machine has and it works! The main partion appears as unallocated so I wipe everything and leave the drive with one partion. Surprise surprise the install fails and fails at the expanding phase.

I figure the hard drive is shot but just to be sure I download the WD diagnostic tool, it finds some bad sectors but says the drive is A OK. Just to be on the safe side I use the write zero option which renders the drive unviewable by windows. I get it solved (yeah internet) and repartioned.

I place it back in the computer, run the install and it goes smoothly all the way to the completing installation phase, it reboots and continues completing, flickers but keeps going then it restarts right into windows error recovery and the message:

The computer restarted unexpectedly or encounterd an unexpected error. Windows installation cannot proceed. TO install Windows, click "OK" to restart the computer, and then restart the installation.

POPS UP every fricken time! I removed the memory one at a time to see if maybe it was that, some forum said to change the voltage setting for the hard drive in the bios but I don't have that option or the AHCI option either. I even tried putting a fan on the machine since I read it maybe overheating (although I thought that couldn't be the problem).

I haven't tried upgrading the bios since well vista was working perfectly fine on the machine so it cant be that right? I read that it could be that I need the driver for sata drive...

I really don't know, I am tempted to just install the windows 7 RC I have laying around but that may cause more problem for me down the road (user related problems). So any ideas?

share|improve this question
    
I was able to get a working vista CD but it just doesn't want to install but I also found an XP CD that I didn't know I had. I got it to run and install only after attaching an IDE CD-rom drive. I then tried to upgrade to Vista but after running the install I got this message: This version of windows could not be installed. Your previous version of Windows has been restored...Before trying this version of windows again, check ... (www.micosoft.com)and search for "upgrade advisor". Well I guess I'll get the drivers installed and check it out, I just might update the bios too. –  Sweetlydark Nov 1 '09 at 13:46
    
Well it says I can install vista which isn't much help (especially after having to update XP in order to run the vista checker, not to mention how difficult it was to find the XP bios drivers to get the Ethernet working), I got the vista drivers extracted in order to try to install them during the vista installation but no luck there either. Asus M2N68-LA drivers: forums.majorgeeks.com/showthread.php?t=156991 –  Sweetlydark Nov 1 '09 at 19:54

1 Answer 1

up vote 0 down vote accepted

Never underestimate the power of a bios update, even when reinstalling the same operating system. The update got Vista installed but I had another problem as well which was that it wouldn't recognize the hard drive unless I went into to the boot options and selected it; even with the boot priority set to just the hard drive. I was thinking it was the boot group options which was set to just CD but I can't edit this no matter how hard I tried. The solution was to just reset the bios to defaults, this got the HD into its boot group and vista is now working fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.