Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 32 bit laptop

I used to be able to open the services but it doesnt open anymore.

I have tried opening it by... - typing "services" in the search box - going to Control Panel\System and Security\Administrative Tools\services

When I click on it, nothing happens. I cant see any errors in event viewer either.

This laptop is part of a domain, and my id has admin privileges. I can open add/remove programs, install/uninstall stuff etc. But services don't open. I have also tried to be on the domain (VPN into work) to make sure its not related to domain not reachable etc.

Not sure how to figure this out.

Thanks A

share|improve this question

migrated from serverfault.com Aug 20 '13 at 18:58

This question came from our site for professional system and network administrators.

    
Probably talk with your IT department. –  EEAA Aug 20 '13 at 17:49
    
What about opening empty console and adding services snap-in manually? –  strange walker Aug 20 '13 at 17:59
    
Added the "services" to an empty console manually. The addition happens and then when I click on the services to open it....it just hangs (Not responding) –  Amit Phatarphekar Aug 20 '13 at 18:04
    
Can you open any other snap-in from that list? And have you tried doing that in safe mode? –  strange walker Aug 20 '13 at 18:07
2  
What if you go to Start, type "services.msc", then right-click and Run as Administrator? –  trpt4him Aug 20 '13 at 19:02

1 Answer 1

I couldn't figure out the culprit, but i went in add/remove programs, sorted by date installed and then uninstalled a whole bunch of programs till a certain date that I knew everything worked right and restarted the machine. After that services opens up now. Thanks for everyone's help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.