Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have set-up Synergy with an OSX server and a Ubuntu host. It's working nicely, except that the mouse wheel doesn't work in Linux. I used to xev command to verify that no input at all is registered when operating the mouse wheel.

I have found various bug reports about this problem, dating back from 2009, but no solution.

I also found a few blog posts where source-code patches can be downloaded. But when I tried to build the code I got errors about a missing i386 directory. (I fear that trying to build the project myself will lead to many hours of frustration..)

Does anyone know where I can download a OSX build with the applied patches?

share|improve this question

I found the answer here

Fix for every installation so far -- I see mostly people using linux as the client so in this scenario I'm using Windows 7 as the server and fedora 12 as the client.

On the client:

tail -f /var/log/messages

now scroll as slow as possible and take note of the errors streaming in.

Example:

Feb  1 18:32:45 localhost Synergy+ 1.3.4:
2010-02-01T18:32:45 WARNING:
Wheel scroll delta (28) smaller than threshold (120)#012#011CXWindowsScreen.cpp,858

This is pretty self-explanatory. Take note of the delta. For this setup, when I scroll slow, I get 28.

So now run this on the client:

killall synergyc; sleep 1; synergyc --yscroll <lowest delta> <ip of server>

Literal example:

killall synergyc; sleep 1; synergyc --yscroll 28 10.0.0.1

Make sure to go through any session files or setting you created to include your new yscroll function.

And don't use 0 or 1 (unless your delta is 1). 0 created some odd issues. You want to set yscroll to your lowest possible literal delta. 0 or 1 neither accurate nor efficient.

share|improve this answer
    
+1 Also, (on a Mac host at least), the Scroll Speed system preference allows some adjustment to the scroll delta. – Seth Sep 27 '15 at 16:52

On Mac in terminal I had to go run: cd /Applications/Synergy.app/Contents/MacOS

Then run: killall synergyc && sleep 10 && ./synergyc --yscroll

Example: killall synergyc && sleep 10 && ./synergyc --yscroll 28 10.0.0.1

share|improve this answer
    
This looks a lot like the two-year-old answer.  What, exactly, are you saying (i.e., what, if anything, are you adding to the existing answer)?  Are you saying that sleep 1 isn't enough?  Are you saying that you need to be in the /Applications/Synergy.app/Contents/MacOS directory for this to work?  Or are you just saying that you don't have that directory in your PATH, and so just running synergyc from an arbitrary directory doesn't work?  … … … … … …  In any case, showing the ./synergyc --yscroll command without all the required parameters is confusing. – Scott Oct 16 '15 at 16:44
    
sleep 1 was not enough, also you need to be in the directory for it to work. – wd4ever Oct 21 '15 at 4:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .