Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

WordPress is creating an empty database, there is a database but with out any values.

I am on local WAMP Server 2.4 (PHP 5.4) Windows 8 Wordpress 3.6 (also tried 3.5.1)

WAMP Apache is Giving some errors I am pasting few lines here:

access.log:

"GET /test_3/wp-admin/css/colors-fresh.min.css?ver=3.6 HTTP/1.1" 304 -
"GET /phpmyadmin/db_structure.php?db=db_test_3&token=4bb71407ccf91fc27d3c8338186ee369&db=db_test_3&ajax_request=true&ajax_page_request=true&menuHashes=572d5b14-cb7c7ed1-ada592ed-4fce1948&_nocache=1376960501429607598 HTTP/1.1" 200 40875

apache_error.log

[mpm_winnt:notice] [pid 7864:tid 468] AH00418: Parent: Created child process 6540
[mpm_winnt:notice] [pid 6540:tid 344] AH00354: Child: Starting 150 worker threads.
[mpm_winnt:notice] [pid 7864:tid 468] AH00422: Parent: Received shutdown signal -- Shutting down the server.

Past-History: I have changed port to :8080 because windows 8 was already using port :80

share|improve this question
    
How did you change to port 8080 and where did you set this? –  M.Bennett Aug 21 '13 at 7:31
    
Along these lines in httpd.conf #Listen 12.34.56.78:90 Listen 8080 #Listen 0.0.0.0:8080 Looking at it i changed it in to: #Listen 12.34.56.78:90 #Listen 8080 Listen 0.0.0.0:8080 And wola database is receiving values now :) but after stetting up wordpress i am receiving this error: "You do not have sufficient permissions to access this page." –  Imran Bughio Aug 21 '13 at 20:32
    
check your wpconfig.php database settings - at some point your settings don't match - plus with phpMyAdmin: check for correct table prefixes, wp_usermeta: wp_capabilities should be a:1:{s:13:"administrator";s:1:"1";} plus wp_user_level 10 –  M.Bennett Aug 22 '13 at 6:45

1 Answer 1

up vote 0 down vote accepted

I found the solution! -- i might have messed this up while changing port.

In httpd.conf -- i had this:

Listen 8080
#Listen 0.0.0.0:8080

Simply changed it to this:

#Listen 8080
Listen 0.0.0.0:8080

Database was receiving values but word-press started giving this error on login attempt

You do not have sufficient permissions to access this page

So i simply went to database and gave my user administrator privileges! (From here i followed the instruction under heading "Editing the wp_usermeta table")

share|improve this answer
    
@Jason Aller I fixed the solution a long time ago and posted answer on stackoverflow. Forgot to add it here as well. –  Imran Bughio May 7 at 18:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.