Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I hav a gigbyte GA-Z77m-D3h mobo and installed Windows 8 Pro and Windows 7 Ultimate on two SSDs (in that order) in EFI mode.

Now when I start my computer, I get the windows boot menu (text mode) with the two OSses to choose, but I have to manually press RETURN to have the computer boot into the Win OS. Even if I wait an hour, no default action takes place.

Using bcdedit (from either of the OSses) I can successfully change the time out value, and it shows up in the bcdedit (no params) output. But it doesn't fire ...

Here is my current BCDEdit output (headers are in German, but values should be readable):

Windows-Start-Manager
---------------------
Bezeichner              {bootmgr}
device                  partition=O:
path                    \EFI\Microsoft\Boot\bootmgfw.efi
description             Windows Boot Manager
locale                  de-DE
inherit                 {globalsettings}
integrityservices       Enable
default                 {default}
resumeobject            {5ad2802c-c60a-11e2-acdb-80331c501b11}
displayorder            {default}
                        {current}
                        {5ad2802a-c60a-11e2-acdb-80331c501b11}
                        {5ad28028-c60a-11e2-acdb-80331c501b11}
                        {5ad28029-c60a-11e2-acdb-80331c501b11}
toolsdisplayorder       {memdiag}
timeout                 5
displaybootmenu         Yes

Windows-Startladeprogramm
-------------------------
Bezeichner              {default}
device                  partition=W:
path                    \Windows\system32\winload.efi
description             Windows 7
locale                  de-DE
inherit                 {bootloadersettings}
recoverysequence        {5ad2802e-c60a-11e2-acdb-80331c501b11}
recoveryenabled         Yes
osdevice                partition=W:
systemroot              \Windows
resumeobject            {5ad2802c-c60a-11e2-acdb-80331c501b11}
nx                      OptIn

Windows-Startladeprogramm
-------------------------
Bezeichner              {current}
device                  partition=C:
path                    \Windows\system32\winload.efi
description             Windows 8
locale                  de-DE
inherit                 {bootloadersettings}
recoverysequence        {5ad28033-c60a-11e2-acdb-80331c501b11}
integrityservices       Enable
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \Windows
resumeobject            {5ad28031-c60a-11e2-acdb-80331c501b11}
nx                      OptIn
bootmenupolicy          Standard
hypervisorlaunchtype    Auto

(this output is from Win8; the Win7 looks nearly identical)

If maybe the problem comes from a bad EFI Windows boot manager installation, can this be fixed without loosing my windows installations?

share|improve this question
    
Have you tried using EasyBCD? It has always worked for me. –  imtheman Nov 3 '13 at 5:45

2 Answers 2

Use BCDEdit to set Windows 8 as the default system and try that boot loader. See if it still does it. For more info on restoring the Windows 8 boot loader see here.

share|improve this answer

The problem vanished when I installed the Windows 8.1 udpate, so I believe refreshing the boot loader would have fixed it, too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.