Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Windows 8 which I installed recently (from factory recovery image) suddenly now takes too long to shut down, around 2 minutes and 20 seconds.

I tried disabling and enabling "Fast Startup" but that didn't affect the shutdown time.

Also reduced the WaitToKillServiceTimeout from 5000ms to 3000ms but also there is no effect. Also the ClearPageFileAtShutdown is set to 0.

I even tried hibernating instead of shutdown and it took 2:20, too!

Also disabled hibernate with powercfg -h off and tried to shut down, and took 2:20, too!

share|improve this question
Have you attempted to remove any external devices( besides keyboard and mouse ) you have installed before you shutdown. – Ramhound Aug 21 '13 at 14:23
there was an external hardisk,I removed it but still the same. – Loers Antario Aug 21 '13 at 14:27
Are you doing an actual power off shutdown or a hybrid shutdown? – Ramhound Aug 21 '13 at 14:29
I just pressed Alt+F4 and chose "Shut down" , what is a hybrid shutdown ? – Loers Antario Aug 21 '13 at 14:32… try doing a full shutdown… – Ramhound Aug 21 '13 at 14:36

Holding Shift while clicking Shutdown will cause the computer to enter a full power off state instead of standby/hibernate. This takes less time than normal shutdown, but your computer will take longer to start up again.

Cheers Peter

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .