Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I tried boot PC - I saw next message:

the disk drive for /media/sdc1 is not ready or not presented
Continue to wait or Press S to skip mounting or M for manual recovery

I used S and now want to know how to solve this issue. Here is my fdisk information:

nazar_art@nazar-desctop:~$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000e28b8

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   310484991   155241472   83  Linux
/dev/sda2       310487038   312580095     1046529    5  Extended
/dev/sda5       310487040   312580095     1046528   82  Linux swap / Solaris

Disk /dev/sdb: 4009 MB, 4009754624 bytes
16 heads, 32 sectors/track, 15296 cylinders, total 7831552 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd8e1f237

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          32     7831551     3915760    b  W95 FAT32

Disk /dev/sdc: 993 MB, 993001472 bytes
2 heads, 1 sectors/track, 969728 cylinders, total 1939456 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1             133     1939455      969661+   6  FAT16

And below blkid info:

/dev/sda1: UUID="5f5d330f-d5f2-4157-9496-94f1dce2f181" TYPE="ext4" 
/dev/sda5: UUID="84747ef4-6f50-49bc-9df1-fcba364ba299" TYPE="swap" 
/dev/sdb1: UUID="8BAA-7FA6" TYPE="vfat"

And the /etc/fstab file info:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc           proc  nodev,noexec,nosuid       0  0  
# / was on /dev/sda1 during installation
UUID=5f5d330f-d5f2-4157-9496-94f1dce2f181  /               ext4  errors=remount-ro         0  1  
# swap was on /dev/sda5 during installation
UUID=84747ef4-6f50-49bc-9df1-fcba364ba299  none            swap  sw                        0  0  
/dev/fd0                                   /media/floppy0  auto  rw,user,noauto,exec,utf8  0  0  
/dev/sdc1                                  /media/sdc1     vfat  noexec                    0  0  
/dev/sdb1                                  /media/sdb1     vfat  defaults                  0  0  
/dev/sdd1                                  /media/sdd1     vfat  uid=nazar_art             0  0  

Update:

now this is output after sudo fdisk -l /dev/sdc running:

Disk /dev/sdc: 993 MB, 993001472 bytes
2 heads, 1 sectors/track, 969728 cylinders, total 1939456 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device Boot      Start         End      Blocks   Id  System
/dev/sdc1             133     1939455      969661+   6  FAT16

Edit:

sudo ls -l /dev/disk/by-uuid/ has next result:

total 0
lrwxrwxrwx 1 root root 10 Aug 21 23:48 5f5d330f-d5f2-4157-9496-94f1dce2f181 -> ../../sda1
lrwxrwxrwx 1 root root 10 Aug 21 23:48 84747ef4-6f50-49bc-9df1-fcba364ba299 -> ../../sda5
lrwxrwxrwx 1 root root 10 Aug 21 23:48 8BAA-7FA6 -> ../../sdb1

And unfortunately any sdc here?

- Why exactly this happen?
- And how to solve this trouble?

share|improve this question
    
Please post the output of sudo fdisk -l /dev/sdc that is the disk that is apparently missing. –  terdon Aug 21 '13 at 16:16
    
@terdon I updated question. –  nazar_art Aug 21 '13 at 18:23
    
Is sdc an external drive? –  terdon Aug 21 '13 at 18:33
    
@terdon yes it is. Do I need update to /etc/fstab for mounting FAT16 and FAT32? –  nazar_art Aug 21 '13 at 18:41
    
@terdon I tried to add /dev/sdc1 /media/sdc1 vfat shortname=mixed,codepage=850,umask=002,uid=1000,gid=100,noauto,user 0 0 to /etc/fstab. But after sudo mount -a have - mount: block device /dev/sdc1 is write-protected, mounting read-only –  nazar_art Aug 21 '13 at 18:51

1 Answer 1

up vote 2 down vote accepted

The main problem here is that since this is an external drive, at the time the system tries to mount it it has not yet been assigned a /dev/sdX name. You should be able to fix this by changing your fstab to use UUID instead.

First, get the UUID of your drive. Run this command when the drive is connected:

sudo blkid | grep sdc

That should return a line that looks something like this:

/dev/sdb1: LABEL="MY_DISK" UUID="ABCDEF123456" TYPE="ntfs" 

ABCDEF123456 is the UUID of your drive. Now, edit your fstab accordingly (replacing ABCDEF123456 with your real UUID of course):

UUID=ABCDEF123456  /media/sdc1  vfat  noexec   0  0  

For more information on persistent naming, have a look at this page from the Arch Linux wiki.

share|improve this answer
    
but one moment this line doesn't have any output ls -l /dev/disk/by-uuid/ | grep sdc. I solved this with a little bit another way by /dev/sdc1 /media/sdc1 vfat shortname=mixed,codepage=850,umask=002,uid=1000,gid=100,noauto,user 0 0 and sudo mount -a after this –  nazar_art Aug 21 '13 at 21:34
    
@nazar_art mount -a should have worked anyway. Read through the arch wiki page I linked to for other ways of getting a persistent name for your drive. What you did is not a solution, you just set the drive to not be mounted automatically. If that is what you want you should also have a look at autofs. –  terdon Aug 21 '13 at 21:58
    
Why it isn't right solution, I can't understand. After all this steps I also add option to samba sudo gedit /etc/samba/smb.conf into [global] section usershare owner only = false. And I didn't have any output after ls -l /dev/disk/by-uuid/ | grep sdc for sdc or sdc1... –  nazar_art Aug 22 '13 at 7:30
    
@nazar_art samba? What does samba have to do with it? And it is not a solution because if you add noauto to fstab, you will need to manually mount the drive every time you need it. If that is OK for you, then great but that was not your original question. I have edited my answer and added a way of finding the UUID of USB drives (sorry for the mistake), it should work now. –  terdon Aug 22 '13 at 11:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.