Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am not sure what I am missing but after updating my httpd.conf file by uncommenting the string to allow httpd-vhost.conf to allow httpd-vhost.conf and update httpd-vhost.conf

update https-vhost.conf file:

# localhost
<VirtualHost *:80>
    ServerName localhost
    DocumentRoot "/Applications/XAMPP/htdocs"
    <Directory "/Applications/XAMPP/htdocs">
        Options Indexes FollowSymLinks Includes execCGI
        AllowOverride All
        Order Allow,Deny
        Allow From All
    </Directory>
</VirtualHost>

# My custom host
<VirtualHost *:80>
    ServerName mysite.dev
    DocumentRoot "/Users/myusername/Projects/myNewsite"
    <Directory "/Users/myusername/Projects/myNewsite">
        Options All
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    ErrorLog "logs/mysite.local-error_log"
</VirtualHost>

and add a new vhost with a new server name.

Last I updated my OX host file with

127.0.0.1  mysite.dev

But when I type http://mysite.dev into the browser the default XAMPP page is displayed.

I also updated the httpd.conf file and changed

User myusername
Group nogroup

Does anyone see anything I missed and why I can not get my site up?

Thanks!

share|improve this question
add comment

1 Answer

I had a few characters in the vhost file that were throwing and error. That is why my host name was not working.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.