Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I try to restart my Ubuntu either from the command line by typing reboot or in GNOME the computer goes from X to console, starts the shutdown process and then a message saying "[ some number ] Starting new kernel" appears on the screen and the computer goes back to X login screen. I suspect this must have something to do with nvidia drivers, because it seemed to have appeared around the time I bought a new graphic card. Also, when I reboot the second time I see weird graphical artifacts on the screen. When I boot from ubuntu live cd I can reboot just fine. I used jaunty, recently I switched to karmic with no change.

This bug is very annoying, because I have to hard reset my computer in order to reboot. Also not good for the filesystems, I suspect.

Can you suggest a way to debug the cause or if not at least the easiest way to go about reinstalling ubuntu without losing customizations/settings/data?

share|improve this question
From a console window, type sudo shutdown -r now and see if you experience the same behaviour. You may be prompted for your root password. – user3463 Oct 31 '09 at 12:55
Tried what you suggested. Seems like with shutdown I go directly to weird artifacts, which I normally see only when I try to reboot the second time. Anyway - same result after this - back to X login. I took a photo of what I see on the screen if anyone is able to make something of that - – VoY Oct 31 '09 at 16:44
up vote 3 down vote accepted

"this is not a bug, but a feature" :)

Just change the line "LOAD_KEXEC=true" to "LOAD_KEXEC=false" in the file /etc/default/kexec.

The motivation is given in the file "/usr/share/doc/kexec-tools/README.Debian".

The corrupted graphic display is normal when reinitialization of the graphic memory is performed at boot, without cleaning the memory before the display.

share|improve this answer
Thanks a lot. You saved me a reinstall, sir :-). – VoY May 23 '10 at 21:13

OK so based on the "artifacts" image you shared, I'm gonna go ahead and blame failing RAM on this. Seriously - it wouldn't hurt to boot up memtest and let it run overnight or over a weekend.

Also, since you're comfortable with installing hardware - make sure everything's seated properly; sometimes cards and RAM are "mostly in" but not all of the way.

share|improve this answer
+1 Even if this isn't the problem, this is worth trying anyway! – Yuval Dec 3 '09 at 7:31
Good idea, I'll try that. Still, this doesn't seem to happen when I boot from live cd, so that's weird. Also, shutdown (as in turning off the machine) works fine. – VoY Dec 3 '09 at 12:08
But even if its failing ram - it's weird that reboot of the machine leads to restart of X. The artifacts appeared the second time I tried to reboot after that happened. I may end up reinstalling the system to be 100% sure, after I try memtest. – VoY Dec 3 '09 at 12:11
Well the default run-level is what's bringing X back up, as the machine reboots back up. FOLLOWUP QUESTION: Do you see the exact same characters, the exact same color, in the exact same locations, every time you see those "artifacts"? – pbr Dec 3 '09 at 15:54
I think I do, yes. Tried different modules, no change - works using live cd though. Still haven't solved this. – VoY Apr 5 '10 at 22:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.