Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I followed the Migration Assistant instructions that say to go to the System Preferences on both computers, enable "file sharing", and then add the files in question to the Public Folder on the source Mac. But when I go to open the Drop Box on the MacBook, a window pops up to inform me that I can't open the Drop Box because I don't "have permission to see its contents."

I've done everything I can think of to enable sharing, but I'm running out of ideas. (And really need my old iTunes library!) SOS!

share|improve this question
add comment

2 Answers

Just to clarify: I assume you mean the OS-X folder /Users/<you>/Public/Drop Box and not the cloud service of the (nearly) same name?

Your ~/Public/Drop Box is one-way inbound, i.e. your local account has read/write permission to it; everyone else (which includes accounts remote to that machine) has write-only.

On your source machine, leave the files in ~/Public - everyone has read-only access to that. Then from your Macbook (or anywhere else), you should be able to read the contents of that folder.

share|improve this answer
add comment

Try this:

On the machine you are sharing your library from:

  1. Go to System Prefs > Sharing > File Sharing
  2. Make sure the Everyone permission is set to read
  3. Under Shared Folders, add the iTunes music folder to the list by clicking + and browsing to the iTunes music folder on your mac.
  4. Click the Options button
  5. Disable AFP (Apple File Protocol) and enable SMB (Server Message Block)

Now on the machine you are trying to copy your files to do the following

  1. browse to Go > Connect to Server
  2. In the Server Address field type SMB:// name/ip address of the machine you are copying from. For example if the source machines IP is 10.10.10.10 you would type SMB://10.10.10.10
  3. Click Connect

I have had some strange issues with shared public folders not being able to be accessed over ethernet for some reason. If the above steps fail, remove the Public folder from the list of shared folders. At that point the only folder under shared would be iTunes Music.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.