Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As I recently upgraded to karmic I started to see the following stuff in the logs when I run VirtualBox:

Oct 30 18:14:34 apocalypse pulseaudio[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)io[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)io[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)io[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)io[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)io[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)io[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)io[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)io[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)io[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)io[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)io[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)
Oct 30 18:14:34 apocalypse pulseaudio[2813]: alsa-source.c: Resume failed, couldn't restore original fragment settings. (Old: 65536/65536, New 1073676288/65532)

After a while the logs grow to large sizes and fill up all of my /var partition. In VirtualBox there is an option to choose between pulseaudio and alsa for sound, but it seems to have no effect. I am using virtualbox-3.0 packages, not the ose version. My system is up to date.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

First please take a look at http://superuser.com/questions/7453/anyone-experiencing-audio-issues-with-virtualbox-on-linux-and-has-a-solution for additional info.

As I note there, from 9.04->9.10 Ubuntu changed from ALSA to PulseAudio for the host sound support.

So you need to tell VirtualBox that your host audio is now PulseAudio - this seems for some reason to be a setting on EVERY virtual machine, so you'll need to change it on all of the ones you run. Changing it on one and not on another is probably a very bad idea.

You'll most probably have to make the change with no VM's running. Then stop and restart virtualbox. Hopefully at that point the messages to /var/log/ will cease.

Failing that, if audio works fine from the VMs and you're still seeing the messages, you might want to take a look at logrotate to manage the logfiles: http://linuxcommand.org/man%5Fpages/logrotate8.html

Hope this helps! If so please give the answer a thumbs-up. Thanks!
-pbr

share|improve this answer
    
Also... sorry it took so long to reply to this! I've been primarily looking at questions tagged "linux" - and this one's not tagged "linux". Now that I know there's a "karmic" tag I'll take a look at the rest of them as well. –  pbr Dec 3 '09 at 3:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.