Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been attempting to connect my Ubuntu 12.04 Virtual Machine to the internet. I have been searching and found some information but have not been successful so far. I have also tried Linux Mint and no network connectivity there either.

My Adapter Settings: Adapter Settings

Ubuntu Network Setup in HyperV UbuntuNetworkSetup

HyperV Virtual Switch Manager VirtualSwitchManager

I'm not sure if this is the issue, but it seems likely. However, anytime I attempt to make the External Switch a Hyper-V Extensible Virtual Switch I get the message shown below and I am unable to set that property. UnableToEnableHyperVExtensible

Any help is appreciated.

If more information is needed please let me know. I tried to be as thorough as possible

share|improve this question
Any reason to not use VMWare Player or VirtualBox? – kobaltz Aug 23 '13 at 3:26
I don't have any experience with VMWare. I tried using VirtualBox and it was always very slow. Also, Visual Studio for Windows Phone development uses an emulator that runs in Hyper-V; VirtualBox and Hyper-V don't like to play nice together. – AndrewK Aug 23 '13 at 3:33
Thanks for the info. I was just wondering. Have always used VirtualBox and QEMU. Never knew why someone would use Hyper-V, but that makes sense. – kobaltz Aug 23 '13 at 12:34
It's nice that it comes with Windows as well, and now that I have an internet connection it works very well. – AndrewK Aug 23 '13 at 12:40
What were the settings for the Internal Virtual Switch? (Sorry I am posting as a question, but I just joined and it says I need 50 reputation points to post a comment ..) – user300704 Feb 17 '14 at 3:23

3 Answers 3

up vote 9 down vote accepted

Well, I figured it out. I had to create an Internal Virtual Switch and then go to the External Virtual switch and share its connection with the Internal Virtual Switch.


share|improve this answer
Im having the same problem now too and I changed the settings here but it still not showing as connected =( – qodeninja Mar 20 '14 at 18:08
Very strange solution! But, works as a charm. Thanks! – Hungry Coder Jan 9 at 17:23

I've read a lot of articles about this issues, and many claim to share the internet connection of the wifi adapter to solve the issue. This did not work in my case. What did work for me, and it should answer your question:

  1. Create an internal virtual switch under Hyper-V.
    a. Open "Hyper V Manager".
    b. Select "Virtual Switch Manager".
    c. Under New Virtual Switch, select "Internal".
    d. Select "Create Virtual Switch".
  2. Shutdown the Ubuntu VM.
  3. Add a legacy adapter with the internal virtual switch that was just created in step 1.
  4. Open "Network and Sharing Center".
  5. Select "Change Adapter Settings".
  6. Select your Wifi Adapter and the Virtual Switch you just made, right click menu option "Create Bridge".
  7. Start the Ubuntu VM.
  8. Login to Ubuntu.
  9. Wait a minute, and the connection should connect.
share|improve this answer

A solution without having to start/restart the guest OS.

1] Delete all the virtual switches and star over.

2] Create an External switch with external network selected either Ethernet or WiFi. (wait for a minute)

3] Now create an Internal switch. (again wait for a minute)

4] Go to Control Panel\Network and Internet\Network Connections and right-click on the External switch, go to Sharing tab and enable the sharing for the Internal switch. (Now, if you don't see a list of network adapters that includes the Internal switch, you may have to start over or wait for a while to let all the changes take effect.)

5] Select the Internal switch for your Linux type guest OS and enable the network in the OS. (You don't need to restart the guest OS at any of the steps) Hopefully your guest OS will connect to the internet as well as internal network.

I've tested & verified this exact process for RedHat7, CentOS7 and Kali Linux.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.