Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm setting up a home server using Ubuntu Server 12.04Lts and I'm trying to connect my Windows 7 desktop to it. However when I try to connect from my windows 7 PC I get a message saying "Windows cannot access \Unbutuserver\Shared Drive Check the spelling of the name"

I'm using the following configuration file

[global] workgroup = WORKGROUP #(Set this to your Windows workgroup) netbios = WORKGROUP #(Set this to your Windows workgroup) security = share [Shared Drive] #(Set this to the name you want the shared folder to have) comment = entire shared drive #(Comments about the shared folder) path = /netstorage #(Path to the shared folder or mount-point of harddrive) read only = no guest ok = yes writable = yes

When I run testparm I get the following

Load smb config files from /etc/samba/smb.conf rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)

Processing section "[glbal]"

Global parameter workgroup found in service section!

Unknown parameter encountered: "netbios"

Ignoring unknown parameter "netbios"

Global parameter security found in service section!

WARNING: No path in service glbal - making it unavailable!

NOTE: Service glbal is flagged unavailable.

Processing section "[Shared Drive]"

Loaded services file OK.

Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions [global] idmap config * : backend = tdb [glbal] available = No [Shared Drive] comment = entire shared drive #(Comments about the shared folder)

   path = /netstorage #(Path to the shared folder or mount-point of harddrive)

   read only = No

   guest ok = Yes

All I'm trying to do is make the "Netstorage" directory, where my RAID5 array is mounted, available to my Windows PC over the network.

Any help you can provide would be greatly appreciated

share|improve this question
1  
Check /etc/samba/smb.conf, that "[glbal]" doesn't seem right. –  week Aug 22 '13 at 10:56
add comment

1 Answer

I had similar issues with Win7 + Samba. Try these registry tweaks, worked for me:

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManWorkstation\Parameters]

DWORD DomainCompatibilityMode 1
DWORD DNSNameResolutionRequired 0

Source: Samba Wiki

share|improve this answer
    
Unfortunately this did not work for me. I'm still getting the same error. I'm thinking that it's possible the error might be on the Windows PC side of things, so I'm going to try to reformat my desktop to see if that helps. –  AWells62 Aug 22 '13 at 19:49
    
Reformatting has not helped the issue as far as I can tell, I tried redoing your registry tip and unfortunately it still did not help. Thank you for your assistance though. –  AWells62 Aug 23 '13 at 10:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.