Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an EEE box with XP Home and a DVI connected TFT, and it does not sleep the monitor. It only starts working after I go to the energy control panel and turn it off and on again. Then the timed sleep works for the current session of computer use. After a shut down and boot next day, sleep does not work again (it is still set in the preferences however).

What can hold the sleep function from working? Are there issues with Skype or MSN? Is there a utility to be less critic to processes interrupting sleep and offer a more reliable monitor sleep function for XP?

share|improve this question
add comment

2 Answers

open your task manager and check whether AsAcpiSrv.exe is running, if necessary reinstall the chipset driver and the Asus ACPI driver (in this order) from your Eee system DVD

share|improve this answer
    
It's not running, but there is no system DVD nor a DVD player in an EEE box. Some way to do it online? –  bert Nov 1 '09 at 11:52
    
Eee PCs don't have a dvd drive alright, but they all ship with a recovery DVD which includes all drivers. and yes, you can get the drivers online from ASUS' support website. –  Molly7244 Nov 1 '09 at 12:31
    
Do you know where I can find a download for this AsAcpiSrv.exe file. I do not have it running, and I can't find it somewhere on the Asus site or other sites. –  bert Nov 8 '09 at 18:26
add comment

A nice article about power management is: An Introduction to Power Management and its Features. You can use it as a checklist to verify the system settings. If this doesn't ring a bell, here are some ideas:

  1. Verify the Power scheme in "Start > Settings > Control Panel > Power Options".
  2. Look in your BIOS for the suspend ACPI options and try to switch it to S3 (suspend to system memory) or S4 (hibernate - suspend to system disk) or a combo such as S1+S3. More info is here and here.
  3. Note: For keyboard wake-up to work, the keyboard settings must enable wake-up from the keyboard. (Start > Settings > Control Panel > Keyboard > Hardware > Properties > Power Management > "Allow this device to bring the computer out of standby" > OK > OK). Same goes for the mouse.
    Keyboard wake-up MUST be enabled for the mouse to be able to wake up the system.
  4. To turn on hibernation (if turned off for some reason), do in cmd run as administrator "powercfg -h on".
  5. See this fix Use this registry file to enable S3 sleep mode in Windows XP. For more info see here.

Note: Any of the above manipulations that doesn't help should be undone.

EDIT

Question: Is this the setting that doesn't "stick":

alt text

share|improve this answer
    
For clarity: I'm not talking about Hybernation and system sleep. The power button hypernates the system perfectly. It's about monitor power-off. I want this to happen after 5 minutes, hybernation can be activated on demand by pressing the power button. –  bert Oct 31 '09 at 17:13
    
Yes, that is the problem-setting. –  bert Oct 31 '09 at 17:30
    
If I change it and choose apply, it works until I reboot the computer. –  bert Oct 31 '09 at 17:30
    
Is your video driver the latest version (from the manufacturer's site, not Windows Update)? –  harrymc Oct 31 '09 at 19:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.