Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My work machine comes with McAfee siteadvisor installed and it places the most inconvenient icon in firefox
enter image description here

This makes it very difficult to add new tabs or navigate to the tabs right under the button. I do not have the permission to disable the button, also I do not want to enable the menu bar as suggested in the McAfee forums.

share|improve this question
    
Why don't you just reconfigure the location of the plugin? I can tell you without the permission to disable it, you likely won't be able to, hide the icon. Why are you against using the menu bar solution? –  Ramhound Aug 22 '13 at 14:18
    
I tried customizing the toolbar layout but the button wont budge,I am using menu bar right now but I don't like being forced to change my ways because of some ill conceived code. –  Shekhar Aug 22 '13 at 14:21
    
In an ideal world you would simply disable it. Since you don't have permission to do that, your options are limited, and likely simply a limitation of the plugin's lack configuration. –  Ramhound Aug 22 '13 at 14:28

1 Answer 1

I finally figured this out :
Install the firefox plugin Stylish and add the following script to it -

/*
 * Do not remove the @namespace line -- it's required for correct functioning
 */
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

#saff-toolbar-items {
    display:none !important;
    visibility:hidden !important;
    }

Source

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.