Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm building a small diskless cluster using PXE boot and a copy of SLES 11 SP1 from a working hard disk install. The kernel fetches over tftp and boots fine, but during boot I see this:

Mounting root 192.168.1.3:/exports/SLES11sp1
mount -o rw,acl,user_xattr -t nfs 192.168.1.3:/exports/SLES11sp1 /root
mount: wrong fs type, bad option, bad superblock on 192.168.1.3:/exports/SLES11sp1

But nfs does not support 'user_xattr'. If I try the mount myself, without the user_xattr option, it works fine. Here's my pxelinux.cfg/default file:

# SLES11sp1 boot
label linux
    kernel vmlinuz-2.6.32.12-0.7-try2
    append root=/dev/nfs nfsroot=192.168.1.3:/exports/SLES11sp1 initrd=initrd-2.6.32.12-0.7-try2 raid=noautodetect
    ipappend 1 

And here's /etc/fstab on the boot image:

192.168.1.3:/exports/SLES11sp1  /   nfs defaults    0 0
proc            /proc                     proc       defaults              0 0
sysfs           /sys                      sysfs      noauto                0 0
devpts          /dev/pts                  devpts     mode=0620,gid=5       0 0
tmpfs           /dev/shm                  tmpfs      defaults,size=4G      0 0

I'm pretty sure that if I can just get the kernel to stop trying to use 'user_xattr' when mounting the root filesystem, it'll work fine? I've already tried

append root=/dev/nfs nfsroot=192.168.1.3:/exports/SLES11sp1,nouser_xattr initrd=initrd-2.6.32.12-0.7-try2 raid=noautodetect

with no luck.

share|improve this question
    
Well, I fixed this by adding rootflags=defaults to the append params in pxelinux.cfg/default. I'd still love to know where the options that it was using were coming from, and how to modify them. Something in mkinitrd, perhaps? –  Adam Cofer Aug 23 '13 at 14:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.