Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I found this before posting my question, but it was pretty unconstructive, so I chose to post a new question anyway....with more details to the problem.

PROBLEM

As the title says, I cannot access any webpage except http://www.google.co.uk/ When I do a google search about a topic, it seems to be working fine...however, when I try to click on a link to follow, it just doesn't work! It has been happening for a while.

Diagnosis so far

  1. Full virus check completed...but you cannot be 100% sure...ever ever...I used Kaspersky 2012.

  2. Deleted all browsing history, form data, passwords, cookies, etc....nothing has changed.

  3. Disabled the wireless adapter and deleted the saved profile for wireless connection. Then re-enabled it. Still no results.

  4. I am pretty sure that my DNS settings are auto-detected. I use DHCP and a home router to connect to the internet. The fact is that I have multiple PCs at home (shared house so different people different PC)...only mine is doing it...

I am currently quite clueless and do not know how to fix this problem apart from trying what I have already written down here. Any help will be appreciated.

Platform

Windows 7 (64-bit) Internet Explorer 9 Mozilla Firefox 4.42 Service Pack 1

** UPDATE SINCE I POSED THIS **

I tried to flush my DNS using 'ipconfig /flushdns' doesn't seem to work after a couple of minutes.

share|improve this question
    
Can you check your hosts.etc file to see if anything is out of works? Can you add more information as to your router model, what kind of apps (like firewals and such) you might be running? It might have to be with the router not accepting connections from your PC so I would give that a check. It might have something to so with the MAC address of the adapter, but since you can access Google, I find it doubtful. –  Doktoro Reichard Aug 22 '13 at 21:14
    
Just before you posted this, I did a ipconfig /flushdns ... It seems to be okay temporarily...but I will do what you have asked...thanks for your comment :) –  hagubear Aug 22 '13 at 21:16
    
@DoktoroReichard I didn't quite understand what you meant by "Out of works"...I checked my hosts file but what is it that I expect there to see? Everything is commented out. I know that when I am doing things like mock server scripting etc. Do I need to uncomment the bit which says 127.0.0.1 localhost ? Does it make any difference though? –  hagubear Aug 22 '13 at 21:23
    
hosts.etc is a file that contains redirects, and some things (most notably Spybot) mess with it (for safety reasons though). It is fine, as you described it, and you should leave it as is. –  Doktoro Reichard Aug 22 '13 at 21:28
    
i used netsh int ip reset C:/resetlog.txt from cmd prompt to reset my ip protocols...it seemed to have worked....for now... –  hagubear Aug 23 '13 at 20:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.