Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 has the full and basic Aero themes that can be changed inside personalization. Windows used to automatically disable Windows Aero (transparency) when I unplug my laptop from the mains.

I reset the theme, and now it doesn't do this anymore. How do I enable this again?

I've checked the advanced power options and control panel but turning back on this feature is eluding me.

share|improve this question

9 Answers 9

up vote 10 down vote accepted

This is how I got it working.

  1. Change the power profile to "Power Saver" (How to: Right click on the battery icon on the desktop > select "Power options" > Select "Power Saver")

  2. Unplug the charger and then go to "Personalize" (right click on the desktop select "Personalize ")

  3. Click windows color > switch OFF "Enable Transparency"

  4. Save changes and exit "Personalize"

  5. Plug in the charger and then go to "Personalize" (right click on the desktop select "Personalize")

  6. Click windows color > switch ON "Enable Transparency"

  7. Save changes and exit "Personalize"

I think this should solve your problem.

share|improve this answer
    
Wonderful, that did the trick. Thanks for the great answer –  Dan Revell Jul 14 '11 at 10:44

I don't know if turn off the theme is supposed to happen, because I can't think of a reason for this software to exist if it did. In any case, that software exists, and looks to work quite well :)

share|improve this answer
4  
You'd be surprised just how much software is written that duplicates some existing function because somebody didn't like what was there (justifiably or not), or because they wanted to figure out how to do it themselves, or just for the hell of it. –  AnonJr Oct 31 '09 at 15:40
    
I think that this software will let you switch between entire power profiles on state change of the mains. Windows only provides limited settings within a single profile. It doesn't let you switch profiles completely. –  Dan Revell Nov 1 '09 at 20:33
    
Windows 7 re-vamped a lot of the power management controls. Dig in to the advanced settings and take a look. –  AnonJr Nov 2 '09 at 17:58

Check the power management settings. It should be in the advanced settings.

Not at a laptop at the moment, but Power Options > Change Advanced Settings

You may need to click on the link to 'view options not visible' (or something to that effect)

share|improve this answer
    
Nope.​​​​​​​​​​ –  Synetech Mar 2 '13 at 3:39

On my computer (a Dell) there is an section in the Advanced power settings called Dell Additional settings. The options in there let you turn off Aero Glass and the sidebar when on battery.

share|improve this answer

Install Vista Battery Saver. It works fine on Windows 7 as I use it myself. Not only can you have it disable Aero when on battery, you can have it switch between power profiles. For instance, I have my laptop run on high performance when plugged in and then it switches to the battery saver profile when running off of the battery.

share|improve this answer

You need to change the visual settings in Windows to "Let Windows choose what's best for my computer".

Start -> Right Click Computer -> Properties -> Advanced System Settings -> Advanced (tab) -> Performance: Settings -> Check "Let Windows choose what's best for my computer"

REBOOT PC

Windows will now disable the aero transparent effect when running on the power saver mode unplugged. Cheers.

share|improve this answer

I recently tried this, I posted last time, but it' still wouldn't change automatically. Try opening til Performance Windows while being in the power saver mode, then choose to disable the aero glass, then goto balanced power scheme, then choose "let windows choose what's best..." now it should work, but it seems that you have to choose it when ur in power saver mode.

share|improve this answer

On my Dell Inspiron 15R, it was the Dell software that was the culprit.

Right Click on the battery icon » Dell Battery Meter » Uncheck "Enable Dell Extended Battery Life".

Then Click Settings below this and uncheck the 'Switch to Windows 7 basic' option.

share|improve this answer

Use Aerofoil I'm using it for years now since Vista RTM and it saved me alot of battery life, it can disable Aero and change the power plan when you're on battery.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.